Jump to content

Logitech X56 RHINO issues WT related


There have been a number of posts on this forum reporting that some axis’s on the Logitech X56 RHINO joystick/throttle set do not work with Macs. I have an iMac running Big Sur, and the X56 controllers work just fine with X-Plane. It also works perfectly with War Thunder Windows version with Bootcamp. This indicates that the problem is with War Thunder’s Mac version. I have joystick/controller testing apps for both Windows and Mac and they all show my X56 to be working perfectly. If just does not work with the Mac version of War Thunder.. Could the developers please look into this? 
 

Share this post


Link to post
Share on other sites
23 hours ago, claykiller said:

There have been a number of posts on this forum reporting that some axis’s on the Logitech X56 RHINO joystick/throttle set do not work with Macs. I have an iMac running Big Sur, and the X56 controllers work just fine with X-Plane. It also works perfectly with War Thunder Windows version with Bootcamp. This indicates that the problem is with War Thunder’s Mac version. I have joystick/controller testing apps for both Windows and Mac and they all show my X56 to be working perfectly. If just does not work with the Mac version of War Thunder.. Could the developers please look into this? 
 

Need more than what you wrote

Your system, shots of the settings, attempts to set keys, etc.

Share this post


Link to post
Share on other sites

I am running a 27" iMac with the most powerful graphics card available and plenty of RAM. I have the Mac version of War Thunder. I am also running the Windows version of War Thunder on Windows 10 through Bootcamp. I have two different joystick testers on the Mac side and the Logitech driver control app on the Windows side. I also have X-Plane on the Mac side. The X56 Throttle and Joystick work perfectly in Windows. They also work perfectly in Mac when used for X-Plane. But when used for War Thunder, the Roll Axis and Pitch Axis do not work. I am attaching screenshots documenting what happens when I try to calibrate the joystick on Windows and Mac War Thunder as well as on X-Plane. I have also attached documentation of my Mac Hardware and Device Overview, as well as my Mac War Thunder settings. I have only included documentation for the Roll Axis because the Pitch Axis performs exactly the same and therefore the extra images would be redundant. Please have the developers look into this. Thank you. 

iMacHardwareDetails.jpg

MacControllerFindings.jpg

MacJoysticDRRIght.jpg

MacJoystickDRLeft.jpg

MacOverview.jpg

MacRollAxisLeft.jpg

MacRollAxisRight.jpg

MacWarThunderSettings.jpg

MacWTRollLEft.jpg

MacWTRollRight.jpg

WindowsRollAxis.jpg

WindowsRollAxisRight.jpg

X-PlaneRollAxisRight.jpg

XPlaneRollAxisLeft.jpg

Edited by claykiller

Share this post


Link to post
Share on other sites
On 23/12/2020 at 12:27, claykiller said:

Pony51, I created another post with all the documentation I can offer. That may not be proper procedure, but you can see it on this forum. Thank you. 

That is OK, I will merge the 2 posts.

Next time please continue existing post, yours or someone else. 

Share this post


Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...