Jump to content

ALL MAC PLAYERS! Turn OFF (uncheck) the "Full Client" in Launcher. Game crash to desktop (work-around)


New bug causing my game to freeze, get fatal crashes and Error code: 8111000D. I can recreate it consistently by getting close to planes on fire, the game freezes and I have to manually close it (unlike the previous crashes that auto-closed the game). Pretty frustrated at this point with this game.

Edited by Dayman
  • Thanks 1
medal

Share this post


Link to post
Share on other sites

Pony have submitted specs multiple times previous with issues relating to the last up[date and game constantly crashing.   Switched over to Catalina and made no impact.   With Full Client on I cant even get into a game - it either crash's out trying to start or when i select a unit in the garage or try to change country.  Switching full client off i actually had a bout 5 games in a row before it hung up - definitely something in this.

  • Thanks 1
medal medal medal medal medal

Share this post


Link to post
Share on other sites

Dear Mr. Moderator - Pony51 -

 

I have playing WT with "Full client" unchecked in the launcher for several days. It does prevent the game from crashing ALMOST every time. My experience is  if I play several games in a row WT will eventually start crashing back to the desktop. 

 

My solution (at least it seems to work as a solution) and new SOP is:

  1. Always launch the game with "Full client" checkbox UNchecked.
  2. Cmd-Q War Thunder at the conclusion of every 2nd or 3rd game.

Now I can at least play through 1, 2 or 3 full games and gameplay is consistently smooth with no crashes.

 

NOTE: If you do uncheck "Full client" be aware of these facts: (A) unchecking Full client deletes all HD graphics data/files (launcher will ask you to  confirm if you want to do this) on a mac, you do until they fix the real issue, the game still runs, just without HD graphics, (B) if you go back to checking "Full client" the game will re-download 15-20GB of HD graphics (and start crashing frequently again).

 

(My setup: 2017 MBP, 3.3GHz i5, 16GB RAM using macOS 11.1 and an AMD Radeon RX 580 in Razer Core X eGPU case)

  • Thanks 1
  • Upvote 1
medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

I can confirm that this works. I am on a Mac running Big Sur 11.1 and had 2 battles this morning without the full client applied. The first battle had 2 crashes the 2nd battle had 3. Read this thread turned off the full client and played 8 battles in a row not a single crash.

  • Thanks 1

Share this post


Link to post
Share on other sites

Try playing different units and modes, which crash more often?

Share this post


Link to post
Share on other sites

I UnChecked Full Client with New Power

 

I still get crashes to desk top, but slightly less so, and i am also seeing more graphical aberrations, such that some Tanks and some planes and in the Hanger i get an individual vehicle/plane rendered without its 'skin' so i just polygon and weird colours.

 

For me there seems to be an equal 'Crash Frequency' across the various modes.

Share this post


Link to post
Share on other sites
17 hours ago, Strontium_DoG said:

Pony51 - i think you may be onto something units and modes - played GreatBritain, Air, AB, around 4.7 BR today and got  straight run of 10 games - then a crash - cleaned out RAM, cache etc and then got another 6 games starught

 

9 hours ago, Drug_smuggler said:

Hi all.

This work around has not worked for me. :dntknw: I presume people have notified tech help,

anybody had any useful feedback? Is it worth putting a ticket in? :017:  

 

On 21/12/2020 at 08:01, nevtiger said:

I UnChecked Full Client with New Power

 

I still get crashes to desk top, but slightly less so, and i am also seeing more graphical aberrations, such that some Tanks and some planes and in the Hanger i get an individual vehicle/plane rendered without its 'skin' so i just polygon and weird colours.

 

For me there seems to be an equal 'Crash Frequency' across the various modes.

 

Thanks for feedback!

 

This is helping narrow search for bug, but it seem there may be many of them.

A guess is assets are not compatible with Metal, causing crashes, it may not be easy to find and fix.

Share this post


Link to post
Share on other sites

Pony, you said

Quote

A guess is assets are not compatible with Metal, causing crashes, it may not be easy to find and fix.

I moved over to Metal a few months back when you called for it to be tested (i.e. well before New Power) and had no crashing issues until New Power was released. So Metal was previously working very well (it improved my frame rate 2x). I'm now having success with no full client (thank you) and haven't had a crash since.

  • Thanks 1
  • Upvote 1

Share this post


Link to post
Share on other sites
On 26/12/2020 at 19:01, OneShotTank said:

Pony, you said

I moved over to Metal a few months back when you called for it to be tested (i.e. well before New Power) and had no crashing issues until New Power was released. So Metal was previously working very well (it improved my frame rate 2x). I'm now having success with no full client (thank you) and haven't had a crash since.

 

New Power introduced Dagor 6 engine.

GJ has been trying to get Metal to work right since 2017, so I assume it was doing well as you experienced.  But Dagor 6 introduced more issues.

Share this post


Link to post
Share on other sites
  • 3 weeks later...
On 26/12/2020 at 20:01, OneShotTank said:

Pony, you said

I moved over to Metal a few months back when you called for it to be tested (i.e. well before New Power) and had no crashing issues until New Power was released. So Metal was previously working very well (it improved my frame rate 2x). I'm now having success with no full client (thank you) and haven't had a crash since.

Same for me. Metal was fine until the New Power update. Whatever change happened then is what did it.

A little late to the party, but I have found that disabling "full client" only somewhat reduces the crashes--it absolutely does not eliminate it, nor would I go so far as to say it significantly reduces it.

medal medal medal

Share this post


Link to post
Share on other sites
On 18/01/2021 at 21:30, fish_outta_water said:

 Whatever change happened then is what did it.

Dagor 6.

New eye candy that crushed Mac.

 

(not that all was well before 2.1, there was a few issues in 1.101)

On 18/01/2021 at 21:30, fish_outta_water said:

A little late to the party, but I have found that disabling "full client" only somewhat reduces the crashes--it absolutely does not eliminate it, nor would I go so far as to say it significantly reduces it.

Yes, that is unfortunate.

Core game is bugged, and full client has more bugs.  :(

Share this post


Link to post
Share on other sites

It's really weird how different it acts for different players, like some people here seemingly still crash on a regular basis, but I myself have not crashed a single time since disabled "full client". I'm no tech expert, it would be nice if someone could explain me these drastic differences.

Also, may I ask wether gaijin is even working on this bug ? I mean I don't wanna make false assumptions, but its been over 2 months already :mellow:

system specs are not that good(really good working pc but old), ima post them in few hours once im on the pc 

 

Edited by FlakHuhn

Share this post


Link to post
Share on other sites
On 25/01/2021 at 10:01, FlakHuhn said:

It's really weird how different it acts for different players, like some people here seemingly still crash on a regular basis, but I myself have not crashed a single time since disabled "full client". I'm no tech expert, it would be nice if someone could explain me these drastic differences.

What is your system specs? (you post somewhere?)

Share this post


Link to post
Share on other sites
7 hours ago, KoPas73 said:

Just to mention that i have played for 2 hours now with the *Full Client* enabled and using the *Work in Progress* client. This without any crash.. Seems that we are getting somewhere!

What is WIP version?

Share this post


Link to post
Share on other sites
13 hours ago, FlakHuhn said:

there u go, pc specs
image.thumb.png.5e26a93260bd7ec5e1834671

Interesting.

 

What is your memory usage?  Open you System Monitor.

10 hours ago, KoPas73 said:

image.thumb.png.7355d613adfcc4eb43aa6afc

Asking version, which is 2.3.0.82

Now is live.  Still running ok?

Share this post


Link to post
Share on other sites
  • 1 month later...

So in order to play around a bit with camos and install some bushes i reinstalled full client a few days ago. I tried to play a match and didn't crash, so i kept it and i never crashed so far, everything seems to work fine (apart from a few bugs i already had before). I only played ground RB at BR 2.3, 3.7, 5.7, 7.0 and 7.7 tho and i didn't play too much (maybe about 40 battles), so i didn't encounter that many aircraft. Can anyone that maybe plays more and different modes report something similar ? Maybe I'm just lucky, but it would be really nice if the crashes are no more.

Share this post


Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...