Jump to content

Cursor issue's on WT home screen and gameplay. (gut)


Sitting on the homepage of War Thunder (Tanks) my up, down, left, and right arrow keys will now control the cursor. The cursor will move to the next "active" object on screen. I have never had this problem until this latest major update. During gameplay (tanks arcade) I controls my tanks with the arrow keys, but now using the arrow keys will cause my aim/view to jump up or down and side to side. This situation makes the game very hard and unpleasant to play. I have played WT for many years and have spent many thousands of dollars and I would love to continue in the future.

Thanks, JB

Screen Shot 2020-11-20 at 10.42.24 AM.png

  • Like 1
  • Thanks 1
medal medal medal medal

Share this post


Link to post
Share on other sites
On 26/11/2020 at 19:47, bigcassssino said:

Sitting on the homepage of War Thunder (Tanks) my up, down, left, and right arrow keys will now control the cursor.

Game plays otherwise?

Sure you settings are not changed?

Need CLOG file and your control settings program. 

Share this post


Link to post
Share on other sites

I am also facing exactly the same issue. This started happening after the 'New Power' update. I tried disabling target tracking, reduced sensitivity, even reinstalled the game but nothing works.

I am playing on 2017 4K iMac running macOS Big Sur.

Here is my clog file from the latest game.

2020_11_29_14_55_25__1603.clog

Edited by Ranger745
  • Thanks 1
medal

Share this post


Link to post
Share on other sites

I'm also having this issue.. I use arrows to steer and a mouse to direct the turret. When I enter sniper mode, the aiming gets very jumpy and the targeting view shifts suddenly making aiming impossible at times. I have tried to reduce the startup settings to Low and still have the problem,though possibly less so, gameplay is perfectly smooth otherwise. Using good computer and AMD Radeon570, FPS good 

Share this post


Link to post
Share on other sites

I am also getting this too, but I do not believe it is a bug as I am also getting it on my pc. It is still really annoying though. When you change a vehicle in your lineup, and use the arrow keys to navigate though the slots to find which one the vehicle is crewed for, it then moves your cursor over that slot. Furthermore you cannot use the enter key to pick the slot you want to use, and have to click "choose crew", so it can get quite annoying having to move the mouse, rather than just using the keyboard.

I attached a clog for good measure, but as I said, I don't think it's a bug.

2020_12_02_17_29_09__96594.clog

  • Thanks 1
medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites
On 30/11/2020 at 11:17, bigcassssino said:

Got the game dowloaded and running again...same problems with the cursor and constant crashing to Mac home screen.

Great!  (was unavailable for a few days)

Read instruction about posting CLOG files, top of Mac section. 

 

18 hours ago, Timmy2222 said:

I'm also having this issue.. I use arrows to steer and a mouse to direct the turret. When I enter sniper mode, the aiming gets very jumpy and the targeting view shifts suddenly making aiming impossible at times. I have tried to reduce the startup settings to Low and still have the problem,though possibly less so, gameplay is perfectly smooth otherwise. Using good computer and AMD Radeon570, FPS good 

Full system and CLOG file please

On 29/11/2020 at 03:44, Ranger745 said:

I am also facing exactly the same issue. This started happening after the 'New Power' update. I tried disabling target tracking, reduced sensitivity, even reinstalled the game but nothing works.

I am playing on 2017 4K iMac running macOS Big Sur.

Here is my clog file from the latest game.

2020_11_29_14_55_25__1603.clog 1.19 MB · 1 download

Full system please.

Share this post


Link to post
Share on other sites
  • 2 weeks later...
  • Pony51 changed the title to Cursor issue's on WT home screen and gameplay. (gut)
19 hours ago, bigcassssino said:

Same issues still going on...game unplayable. This has been going on over a month now!!! :ready:

Why are me and others not getting any support on this???

 

v2.1 is indeed a much bigger update in core engine than expected, bugs on all platforms.

 

(Meanwhile others are clamoring for more units, more and better weapons.)

 

Data is being passed on.

Share this post


Link to post
Share on other sites
  • 3 weeks later...

EVERY THING else seems to be working now, but this problem hasn't been solved yet. I deleted all the files and reinstalled the game fresh, the texture problems are now gone but this hasn't.

Please give an update on this issue.

It has been very long time.

Have you detected this problem.?

medal

Share this post


Link to post
Share on other sites

OKAY, I think i fixed it.

I reassigned my throttle and steering keys to I J K and L (you can choose any except your standard arrow keys), and it worked.

For some reason the issue is present only with the arrow keys.

If someone can explain this then please do.

 

I think there is a bug in the game that somehow links the cursor to the arrow keys, so whenever we press these arrow keys, the cursor starts to jump here and there.

You can also notice this in the hangar when you press the arrow keys, the pointer starts to move.

Edited by Ranger745
medal

Share this post


Link to post
Share on other sites

Is anyone attending to these problems??? Same issues and it seems nothing is being done. Gaijin support act as if its not their problem??? Why does Gaijin support even exist then???

Sooo frustrating!

  • Like 1
medal medal medal medal

Share this post


Link to post
Share on other sites

Can people give me FRESH CLOG files?

Your system info if not added to this report.

Share this post


Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...