Jump to content

Vulkan related issue after New Power update


Most of the time it fails right after launch (during black screen) on vkQueueSubmit()

image.thumb.png.2ee31c4929440aebddbe3761

 

Sometimes it fails on vkWaitForFences()

 

image.thumb.png.b23630ddd7ca1af3533fc2e9

 

Ubuntu 20.04 (5.4.0-54-generic), GeForce MX150. Latest stable Nvidia driver 455.

 

inxi -F output

 

System:    Host: ERPU-MI Kernel: 5.4.0-54-generic x86_64 bits: 64 Desktop: Gnome 3.36.4 
           Distro: Ubuntu 20.04.1 LTS (Focal Fossa) 
Machine:   Type: Laptop System: Timi product: TM1701 v: N/A serial: 16771/00108368 
           Mobo: Timi model: TM1701 v: MP serial: MMG5S000001178ABP00B8 UEFI: INSYDE v: XMAKB5R0P0906 date: 10/23/2018 
Battery:   ID-1: BAT0 charge: 57.8 Wh condition: 57.8/60.0 Wh (96%) 
CPU:       Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP L2 cache: 8192 KiB 
           Speed: 800 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel 
           Device-2: NVIDIA GP108M [GeForce MX150] driver: nvidia v: 455.38 
           Display: server: X.Org 1.20.8 driver: modesetting,nvidia unloaded: fbdev,nouveau,vesa resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce MX150/PCIe/SSE2 v: 4.6.0 NVIDIA 455.38 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k5.4.0-54-generic 
Network:   Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi 
           IF: wlp2s0 state: up mac: 14:4f:8a:7a:a4:f9 
           IF-ID-1: br-4f8f28a70c25 state: down mac: 02:42:97:6d:2a:20 
           IF-ID-2: br-701191e7976a state: up speed: N/A duplex: N/A mac: 02:42:fd:35:fe:5a 
           IF-ID-3: docker0 state: down mac: 02:42:86:f9:df:7a 
           IF-ID-4: veth4d252c1 state: up speed: 10000 Mbps duplex: full mac: 92:9d:55:e0:44:89 
           IF-ID-5: veth6b75640 state: up speed: 10000 Mbps duplex: full mac: ee:13:16:a1:3c:e4 
           IF-ID-6: vethb568e7f state: up speed: 10000 Mbps duplex: full mac: 96:55:c7:1f:ec:2a 
           IF-ID-7: virbr0 state: down mac: 52:54:00:70:74:6e 
           IF-ID-8: virbr0-nic state: down mac: 52:54:00:70:74:6e 
Drives:    Local Storage: total: 238.47 GiB used: 412.81 GiB (173.1%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB256HAHQ-00000 size: 238.47 GiB 
Partition: ID-1: / size: 233.24 GiB used: 206.40 GiB (88.5%) fs: ext4 dev: /dev/nvme0n1p2 
Sensors:   System Temperatures: cpu: 52.0 C mobo: N/A gpu: nvidia temp: 46 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 474 Uptime: 2h 35m Memory: 15.52 GiB used: 6.37 GiB (41.0%) Shell: bash inxi: 3.0.38 

 

 

2020_11_21_15_50_48__28367.clog

Edited by lem8r
added inxi -F and clog

Share this post


Link to post
Share on other sites

I'm having the same issue. but it fails consistently right after launch every time. fedora 30, mate desktop   
*I litterally haven't been able to play new power because vulkan(which I used beforehand) is completely screwed


should I just bite the bullet and go back to Proton? vulkan used to be my magic bullet. but now it keeps me from playing the game. and I've heard nothing about this bug being fixed

Screenshot at 2020-11-21 06-54-47.png

Edited by muse2020
  • Like 1

Share this post


Link to post
Share on other sites
  • 1 month later...

I am having the same issue, however I am running an R9 290. For me, switching to AMDGPU instead of RADV fixed it. You can have both RADV and AMDGPU installed at the same time, here's how you can check what you have installed:

ls -ln /usr/share/vulkan/icd.d

Here if you see amd_icd64.json, that means you have AMDGPU, radeon_icd stands for RADV.


You can then go to Lutris -> War Thunder -> Configure -> System Options and select Vulakn ICD loader to be amd_icd64.json. If you're not using Lutris, you can set env variable and then launch WT:

cd 
<WT_directory>

VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/amd_icd64.json ./launcher

I am not aware how nvidia works or if this has been resolved for green team, I guess you can try different drivers too, but this got the game working for my AMD gpu.

Edited by Kayne_92
Correct GPU name
medal

Share this post


Link to post
Share on other sites
  • 3 weeks later...

hi , i tried running this game on Ubuntu 20.10 , i3 3110m ,running it with its intergrated gpu Intel HD 4000,  4gb of ram , i tried Kayne_92 suggestion, got the same error, but got this output on the terminal that i have no idea what does that mean

[email protected]:~/.local/share/Steam/steamapps/common/War Thunder$ VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/intel_icd.x86_64.json ./launcher
INTEL-MESA: warning: Ivy Bridge Vulkan support is incomplete
[email protected]:~/.local/share/Steam/steamapps/common/War Thunder$ [S_API FAIL] SteamAPI_Init() failed; no appID found.
Either launch the game from Steam, or put the file steam_appid.txt containing the correct appID in your game folder.
INTEL-MESA: warning: Ivy Bridge Vulkan support is incomplete
[email protected]:~/.local/share/Steam/steamapps/common/War Thunder$ INTEL-MESA: error: ../src/intel/vulkan/anv_device.c:3263: GPU hung on one of our command buffers (VK_ERROR_DEVICE_LOST)

 

Share this post


Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...