Jump to content

Game launcher won't launch after "updating vulkan shaders" every time


On 17/11/2020 at 19:28, orfi12 said:

 

Ubuntu 20.04 here. Same problem with the launcher. I get the  PM:missing image crash.

 

For people not able to start the launcher via Steam have you tried launch option: env LD_PRELOAD="" %command% . It does work for me.

Thank you, this launch option worked fine for me. Now (since today) there is another Problem, the smoke is now a black bunch of pixels. I think that is the result of the last Vulkan update of today.

Share this post


Link to post
Share on other sites
On 17/11/2020 at 21:28, orfi12 said:

 

Ubuntu 20.04 here. Same problem with the launcher. I get the  PM:missing image crash.

 

For people not able to start the launcher via Steam have you tried launch option: env LD_PRELOAD="" %command% . It does work for me.

 

Thank you man! You saved me a lot of time. I tried it on Void Linux and the client in Steam works again!

medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites
On 17/11/2020 at 21:05, Kanonenfutter20 said:

Which kind of graphic  do you have, AMD or Nvidia?

 

i managed to start a gnome session on opensuse 15.2, launcher started, got into the hanger, could do test drives etc, started a battle but as soon as the battle started a got a fatal exception and the game crashed. (joining random battle was the last message on the screen) I have a Nvidia Geforce 1070. My wild guess its a combination wayland with nvidia problem

with 2.1.0.36 the "black screen when in focus" is gone I can start the game launcher as before the update and get into the Hangar. But I can't join any battle, always get an exception fatal error before joining the battle. I will file a detailed bug report later.

 

Meanwhile can somebody confirm or deny if he as a working configuration with any Nvidia card ? If it works and joining a battle is working ,  which Nvidia card and which distro ?

 

My systems, (not working joining a battle) OpenSuSE Leap 15.2 Nvidia Geforce 1070 and Nvidia GeForce RTX2080 Mobile

 

 

medal medal medal medal medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

---IT WORKS FOR ME NOW---

 

Linux Mint 20 user here.

 

With Cinnamon Desktop and xOrg display server, after the recent update the game starts fine, no black screen issue and no black smoke issue neither.

It still does not start from steam, but if I start the launcer or the game, it works fine!

 

The game runs now buttery smooth for me. I have the same FPS on my system (i5-4690+RX480) as on windows! :biggrin:

The new engine and game version still might have some issues, but the Vulkan update is a major leap forward!!!

Edited by Balazs_hun
medal

Share this post


Link to post
Share on other sites
21 hours ago, Kanonenfutter20 said:

with 2.1.0.36 the "black screen when in focus" is gone I can start the game launcher as before the update and get into the Hangar. But I can't join any battle, always get an exception fatal error before joining the battle. I will file a detailed bug report later.

 

Meanwhile can somebody confirm or deny if he as a working configuration with any Nvidia card ? If it works and joining a battle is working ,  which Nvidia card and which distro ?

 

My systems, (not working joining a battle) OpenSuSE Leap 15.2 Nvidia Geforce 1070 and Nvidia GeForce RTX2080 Mobile

 

 

Meanwhile I set up Opensuse tumbleweed from scratch and made a fresh WT installation (Tumbleweed always has the newest drivers but could be unstable) and now the game works for me.

 

OpenSuSE Leap 15.2 with a fresh WT installation still crashes, so it looks like a driver/lib version problem

 

Edit1 : After following the EAC thread I manually upgraded Opensuse Leap 15.2  with glibc 2.27 and now it works, I can enter battles Naval, Tank AB and RB without any crash so far.

 

Edit 2 : My advice for similar problems : check the wt libs with ldd <libname> to see if  you have all the required lib versions

 

Edited by Kanonenfutter20
medal medal medal medal medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

Hello @apemax,

 

So I've gone through the trouble of uninstalling the game in Steam, reinstalling it, and the same issues occur: game won't start from Steam, using "launcher" I get "INTEL-MESA: warning: Haswell Vulkan support is incomplete" error message, and using "aces" I get the same screenshots in my previous post. I then removed the game completely from Steam again and downloaded the Linux version from the War Thunder website. Again, using the "launcher" app I get the same INTEL-MESA error message, and the launcher window is transparent and closes after about 10 seconds.

 

This is all on Nvidia driver version 455.38. Could the video driver have anything to do with the issues I'm having getting the game to launch? Mind you, no other games of mine are having issues, whether I launch them from Steam, Lutris, or a standalone launcher (e.g., Minecraft).

Edited by derklempner
medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

hmm, do you have a notebook with a hybrid graphic card ? Error messages says INTEL-MESA and not Nvidia.

Google your error message and you find a lot of hints. Without more info about your hardware it is difficult to say more.

If you have a hybrid card my (wild) guess is, for a unknown reason the nvidia card is not activated and your system uses the processor graphic

 

I had a GeForce 1070, have a GTX3070 and a GTX 2080 mobile, all running fine after lib upgrade and with 2.1.0.47

medal medal medal medal medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites
19 hours ago, Kanonenfutter20 said:

hmm, do you have a notebook with a hybrid graphic card ?

 

No, desktop PC with GTX 970. My hardware info is all in my second post in this thread.

 

Quote

I had a GeForce 1070, have a GTX3070 and a GTX 2080 mobile, all running fine after lib upgrade and with 2.1.0.47

 

What lib upgrade? What distro are you using? What driver version?

Edited by derklempner
medal medal medal medal medal medal

Share this post


Link to post
Share on other sites
6 hours ago, derklempner said:

 

No, desktop PC with GTX 970. My hardware info is all in my second post in this thread.

 

 

What lib upgrade? What distro are you using? What driver version?

Spoiler

inxi -F
System:    Host: Darkstar3 Kernel: 5.3.18-lp152.50-default x86_64 bits: 64 Desktop: KDE Plasma 5.18.5
           Distro: openSUSE Leap 15.2
Machine:   Type: Desktop Mobo: ASUSTeK model: PRIME X399-A v: Rev 1.xx serial: <superuser/root required>
           UEFI: American Megatrends v: 1203 date: 10/09/2019
CPU:       Topology: 8-Core model: AMD Ryzen Threadripper 1900X bits: 64 type: MT MCP L2 cache: 4096 KiB
           Speed: 2096 MHz min/max: 2200/3800 MHz Core speeds (MHz): 1: 2130 2: 2091 3: 2139 4: 2194 5: 2190
           6: 2194 7: 2190 8: 2193 9: 2155 10: 2168 11: 1888 12: 2125 13: 2076 14: 2036 15: 2130 16: 2195
Graphics:  Device-1: NVIDIA driver: nvidia v: 455.45.01
           Display: x11 server: X.Org 1.20.3 driver: nvidia resolution: 2560x1440~60Hz
           OpenGL: renderer: GeForce RTX 3070/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01
Audio:     Device-1: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel
           Device-2: NVIDIA driver: snd_hda_intel

 

OpenSuSE Leap 15.2, details see above, for the RX2080 mobile I use 450.80.2, for the GTX3070 455.45.01

You need glibc-2.27 or newer, to check go to <homedir>/WarThunder/linux64 and check so output of    ldd aces   and   ldd easyanticheat.so      for missing libs

you may also check with inxi -F which graphic and driver is used

 

OpenSuse Leap 15.2 comes with glibc-2.26, so I searched for community package for leap 15.2 which provides the glibc-2.27

But with glibc 2.26 you can start launcher and get into the Hangar, only when u start a battle it crashes.

 So I guess its more a graphic driver problem in ur case

Edit 1: Im using the warthunder launcher from gaijin website

Edit 2 : ihmo your processor should have a build in graphic intel HD4600, my guess for an unknown reason your system uses this graphic in stead of Nvidia.

Edited by Kanonenfutter20
medal medal medal medal medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

@derklempner,

 

There was another player with the same problem as you, The game looks to be trying to run on your Intel iGPU, Do you have you iGPU disabled in your BIOS and your primary GPU set to your PCIe GPU?

Share this post


Link to post
Share on other sites

Since I didn't get Wt under 15.1 running anymore, despite driver updates
I upgraded to 15.2, WarThunder completely new native installation, hidden folders in .config deleted too.


Laptop:   Lenovo G780
CPU:      Intel i5-3230M 2.6 GHz
Graphics: Intel HD3000
          NVIVIDA GF108M (GeForce GT 635M)
RAM:      8 GB

 

Software

OS: OpenSuSE Leap 15.2
Desktop: KDE/Plasma

Drivers:

libdrm_nouveau2           2.4.100-lp152.1.4
libdrm_nouveau2-32bit     2.4.100-lp152.1.4
nvidia-computeG04         390.138-lp152.31.1
nvidia-gfxG04-kmp-default 390.138_k5.3.18_lp152.19-lp152.31.1
nvidia-glG04              390.138-lp152.31.1
suse prime                0.7-lp152.31.1
x11-video-nvidiaG04       390.138-lp152.31.1
xf86-video-nv             2.1.21-lp152.3.4
libvulkan1                1.2.133-lp152.1.3
libvulkan1-32bit          1.2.133-lp152.1.3
libvulkan1_intel          19.3.4-lp152.27.1
libvulkan1_intel-32bit    19.3.4-lp152.27.1
vulkan-tools              1.2.133-lp152.1.3

 


Installed glibc 2.27 from
https://software.opensuse.org/package/glibc

Hit button below -> showglibc for other distributions
Hit red button for 15.2 Leap -> show community packages
Choose -> home:cabelo:Intel community -> 1-click installation
Restart your machine.

After login open console and change display to nvidia driver with su and type:

prime-select nvidia.

Logout
Login again, you might not see your password as you are typing it in the input field now,
but it's detected when you hit return.

 

Different behaviour of launcher and game, depending on selection of plasma varaint on login screen:
1. plasma (default)

1.a starting launcher from GUI
launcher opens with a transparent window without content and closes automatically after about half a minute.
1.b starting from console as user ./ launcher gives you more information:

INTEL-MESA: warning: Ivy Bridge Vulkan support is incomplete

Speicherzugriffsfehler (Speicherabzug geschrieben)  ->translated: memory access error (memory dump written)
related log/dump files: 13_58

1.c starting game from console as user from linux64 folder ./aces, game crashes:

[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
INTEL-MESA: warning: Ivy Bridge Vulkan support is incomplete


A popup opens (Kritischer Fehler) with the message:
Stopp (Freeze) erkannt. [8111000A]
Weitere Informationen^M

auf <a href="https://support.gaijin.net....
after confirming with ok another popup opens
with some message like freeze detected aces 7 frames or something like that.
I couldn't make a screenshot, because desktop was nearly unusable and I only could confirm that.
I noticed there was another popup open in the background with vulkan in its title,
but it closed automatically when I closed the second popup.

related dumps: 14_24

2. plasma wayland
2.a starting launcher from GUI

launcher starts without problems and behaves as it should, searching for updates etc...

2.b starting game from launcher
game opens login screen and after login it renders the intermediate screen, but crashes when trying to open the hangar.
Popup with error message : wt_callstack.png

2.c starting game from console as user from linux64 folder ./aces, game crashes at the same point:

[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
Xlib:  extension "NV-GLX" missing on display ":1".
INTEL-MESA: warning: Ivy Bridge Vulkan support is incomplete
INTEL-MESA: error: ../src/intel/vulkan/anv_device.c:2936: GPU hung on one of our command buffers (VK_ERROR_DEVICE_LOST)

logs and dumps appended too: 14_30 and later

Might that help You to find the reason for the problems
 

 

 

2020_11_29_13_58_28_19235.txt 682bc90f-9a7e-4f72-2c78b81e-3551a11f.dmp 2020_11_29_13_58_28_19235.txt.fatal.txt 2020_11_29_13_58_28_19249.txt 4812a3ad-166b-b94a-5e7505e8-7589308e.dmp 2020_11_29_14_24_42__19573.clog

wt_callstack.png

2020_11_29_14_48_17__20762.clog 2020_11_29_14_42_07__20507.clog 31067578-3e86-b726-154339f6-2bd2cd9f.dmp 4812a3ad-166b-b94a-5e7505e8-7589308e.dmp 2020_11_29_14_24_42__19573.clog 2020_11_29_14_40_24_20375.txt 2020_11_29_14_40_23_20355.txt

Edited by GiffiMarauder
More details

Share this post


Link to post
Share on other sites

Hello @GiffiMarauder,

 

Do you have the nvidia-prime package installed? You can find out by running this command:

 

sudo apt-get install nvidia-prime

If you don't, Please install it then run the launcher with this command again:

 

__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia ./launcher

That should launcher the game on your Nvidia GPU instead of your Intel iGPU.

Share this post


Link to post
Share on other sites

Hi apemax,
For the latest nvidia-computeG04 driver as described above I already included and activated the original NVIDIA repo
https://download.nvidia.com/opensuse/leap/15.2

I suppose suse-prime is the adapted version of nvidia-prime.
Despite of that the special launcher start you described doesn't make any difference under plasma default (no wayland).
But gave it a try and got this:
 

:~> sudo apt-get install nvidia-prime
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...
'nvidia-prime' wurde in den Paketnamen nicht gefunden. Fähigkeiten werden durchsucht.
Keine Anbieter von 'nvidia-prime' gefunden.
Paketabhängigkeiten werden aufgelöst...

Keine auszuführenden Aktionen.

Zypper and YaST softwarecenter too can't find any package similar to that name.
Conclusion: native nvidia-prime isn't available for openSUSE Leap 15.2.

But prime-select does work, I definitely can switch between Intel and NVIDIA graphic controllers.

Any other ideas?

 

Edited by GiffiMarauder

Share this post


Link to post
Share on other sites
On 27/11/2020 at 11:13, apemax said:

@derklempner,

 

There was another player with the same problem as you, The game looks to be trying to run on your Intel iGPU, Do you have you iGPU disabled in your BIOS and your primary GPU set to your PCIe GPU?

 

@apemax,

 

I checked the BIOS, here's what I saw:

 

BIOS-iGPU.thumb.jpg.c35bc3a96be3dc28ddbf

 

As you can see, the PCIe GPU was the primary adapter. I changed the Share Memory from 512MB to AUTO, and the game started working again. I don't know what was changed during that WT update, but whatever it was somehow was affected by the BIOS settings -- unlike beforehand. Thanks for sticking with me through the issue. It's been a couple of weeks, it'll be nice to get back to the game on a decent PC.

medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

Hi derklempner ( Meister Röhrich oder watt? ;) ),
my Lenovo notebook has one configuration item called graphics device where you can choose between
switchable graphics

or
UMA

and is set to switchable graphics as default.
And from google infos I understand that UMA is the intergrated Intel graphics.
Hence enabling the NVIDIA GPU has to be done via software.
This works by using suse-prime because with su I can see:

 

# lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 635M] (rev a1)

# prime-select nvidia

Logout to switch graphics


And looking into the generated
etc/X11/xorg.conf.d/90-nvidia.conf
shows disabled Intel:
 

Section "ServerLayout"
    Identifier "layout"
    Screen "nvidia"
    Inactive "intel"
    Inactive "modesetting"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Section "Device"
    Identifier "intel"
    Driver "intel"
EndSection

Section "Screen"
    Identifier "modesetting"
    Device "modesetting"
EndSection

Section "Device"
    Identifier "modesetting"
    Driver "modesetting"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1:0:0"
    Option "DPI" "96 x 96"
    Option "AllowEmptyInitialConfiguration"
    Option "AllowExternalGpus"
EndSection

 

something wrong here maybe?

but checking for selected gpu seems to be ok:
 

:~> xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x2f9; cap: 0x1 (Source Output); crtcs: 2; outputs: 1; associated providers: 1; name: NVIDIA-0
    output VGA-0
Provider 1: id: 0x46; cap: 0xf (Source Output, Sink Output, Source Offload, Sink Offload); crtcs: 3; outputs: 4; associated providers: 1; name: modesetting
    output LVDS-1-1
    output VGA-1-1
    output HDMI-1-1
    output DP-1-1


What else to check?
 

 

Edited by GiffiMarauder
more details

Share this post


Link to post
Share on other sites

nearly a year ago I had also a Laptop  with a switchable graphics, but I ditched it  for a mobile workstation with a fixed graphic card so I'm writing this from memory :

 

I had to install bumblebee (Opensuse 15.1) and started with this command WT on a (user) command line aka Konsole :

 

blank_mode=0 optirun -b primus /usr/sbin/exec "<yourhomedir>/WarThunder/launcher"

 

Use it on your on risk, it worked on a Dell Laptop for me.

Edited by Kanonenfutter20
medal medal medal medal medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

@GiffiMarauder,

 

Right, After looking into you GPU unfortunately the GT 635M (A Fermi 2.0 GPU) does not support Vulkan and WT now uses Vulkan for both launcher and game client. Your Intel iGPU supports the Vulkan 1.0 spec but clearly it isn't working either as WT may need a newer Vulkan spec.

 

@derklempner,

 

Right, Well glad to here that sorted your problem. I'll keep that in mind if I come across this again. Thank you.

  • Like 1

Share this post


Link to post
Share on other sites
  • 3 weeks later...

War thunder was rendering black window and out of focus workaround wouldn't work. I am using an optimus GTX1050 + HD630 laptop and figured war thunder was trying to use intel vulkan implementation instead of nvidia's, although I am running nvidia performance mode. With:

VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/nvidia_icd.json ./launcher 

launcher successfully launched and is rendered properly. So I leave this here since I didn't find it suggested yet.

  • Like 1

Share this post


Link to post
Share on other sites
  • 2 months later...

Ok I have fixed this in a (Beginner to linux) type way  Install or open Synaptic Package manager or Muon Package Manager if Kubunntu Search "Mesa" install these 2 packages "Primus-Nvidia" And Bumblebee-Nvidia (Nvidia Card ofcoarse).  They help stoping the breakage of 3d issues  Restart computer and try it...  worked for me... Hope this helps so All can get back to playing War Thunder on Ubuntu based OS's Play on all :)

 

Edited by Unlucky_Square
Used term Ace, meant for "beginner to linux users"

Share this post


Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...