Jump to content

Game launcher won't launch after "updating vulkan shaders" every time


25 minutes ago, Unaimed73509 said:

 

I set the game to run in windowed mode, so i can actually see what is going on there, and it is absolutely gorgeous now. I went from having "barely playable" (40-some FPS) in ULQ settings to (now) benchmarking 90-70 FPS with graphics set to the default "max" settings. Unfortunately, when focusing the game window itself it all goes black.

 

I had this issue after updating the game and had an error afterwards:

PM: missing picture 'laures/skin#2_0_main_window_bg_art' in static atlas 'laures/skin' (1 pics missing)

 

downloading a fresh installer from the website and extracting files into my WT directory fixed this issue

 

This works for the steam install as well? I currently can't start the launcher due to seg fault, even after reinstall through steam. Currently can't play the game due to it requiring an update through the launcher. Which won't launch.

Your response doesn't help because the launcher won't work to allow for an update because apparently people pushed the broken update for the launcher to steam. Go figure.

Edited by Fluffy_Bucketles

Share this post


Link to post
Share on other sites
1 minute ago, Fluffy_Bucketles said:

This works for the steam install as well? I currently can't start the launcher due to seg fault, even after reinstall through steam. Currently can't play the game due to it requiring an update through the launcher. Which won't launch.

 

Sorry, can't help you with that one, I was actually never able to launch war thunder from steam, just checked again and still can't. I always used the launcher.

 

I think that you might be able to fix this like I did though, download the latest linux installer from warthunder.com and extract all files from it (overwrite) to probably (but check it first!)

~/.steam/steam/steamapps/common/War\ Thunder/


 

medal medal medal

Share this post


Link to post
Share on other sites
1 hour ago, venoma333 said:

I'm also getting the black screen issue, but both at the launcher and after launching the game (either from aces or the launcher). I can see the game is running correctly in the background, but upon focusing the window, both of my screens turn black until I unfocus the game window. I'm using an NVIDIA GTX 1070 with the 455 drivers on the 5.9 kernel, and Vulkan has been configured to work properly as I can use it in other games without issue. I was playing the game normally on OpenGL yesterday, so this is definitely related to the update. Also, I'm using KDE Plasma, so that might be related. I'll try doing more tests later when I'm free. Please let me know if there are logs I should provide. Starting the game through the terminal yielded no useful logs.

 

P.S.: Thank you apemax for helping out in these forums! I've only been lurking here, but I see you posting in every thread so I just want to say thanks for that :)

I can confirm the exact same behavior, thx for reporting so I know I'm not alone, two different machines, Opensuse 15.0 + 15.2 and 2 different Nvidia cards.

Worked  perfectly until the update => I guess an vulcan issue

Edited by Kanonenfutter20
medal medal medal medal medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

same problem. Put the game in window mode and now I see stuff - as long as the warthunder window is not in the foreground. As soon as I click on it or remove the last window in front of it: bam black screen.

 

This is in plasma. Will try lxqt  later.

Share this post


Link to post
Share on other sites
31 minutes ago, Kanonenfutter20 said:

I can confirm the exact same behavior, thx for reporting so I know I'm not alone, two different machines, Opensuse 15.0 + 15.2 and 2 different Nvidia cards.

Worked  perfectly until the update => I guess an vulcan issue

 

I'm pretty sure it is not directly binded to game. I started to have launcher black screen issue few days ago, it was one or two days after last small update, One day it was fine, other went dark. 

- I was not updating any drivers and game alone was also not updated in meantime.

- I had some other linux stuff updated. That might be connected with kernel upgrade. I'll test this idea after i'll finish my distant learning for today. Also there is new kernel update waiting to be applied. - Will edit/post results.

 

Main linux updates are installed after restart. I've checked history and it updated intel-microcode, python3, openjdk and network manager. Day before i had kernel update from 5.4.0-52.55 to 5.4.0-53.56, now 5.4.0-54.57 is waiting.

 

EDIT:

After installing new kernel issues are still present.

Edited by SzymonKurzacz
Information update

Share this post


Link to post
Share on other sites

===IT WORKS UNDER WAYLAND===

Hello Everyone,

 

Linux mint 20 user here on Linux kernel 5.9.8

I had all the problems, what the previous users described. Steam updated the vulkan shader and then it just simply did not launch.

Running the launcher directly or the game resulted in a black screen, but if I switched to another window, then I was able to see the contents of the launcher or the game and saw in the game header, that it runs under vulkan now.

 

VAH1976 mentioned it works under wayland. I quickly installed the gnome desktop on linux mint 20, switched to it and viola, War Thunder runs now.

So I guess the issue is with War Thunder linux and it does not like xOrg or Xsession, which is still the majority for linux.........

I guess this is why we do not see any Ubuntu 20.04 users complaining here.

Edited by Balazs_hun
  • Thanks 1
medal

Share this post


Link to post
Share on other sites

Thanks for discovering that it works with Wayland!

 

For KDE users: In your regular KDE session, you can start a nested Wayland KWin by doing

kwin_wayland path/to/aces

The launcher did not work for me like that so I had to launch it normally to update.

 

EDIT: Please disregard. I was running the older version of the game at that point and was misled by it starting normally.

Edited by venoma333
  • Thanks 1
medal medal

Share this post


Link to post
Share on other sites
17 minutes ago, venoma333 said:

Thanks for discovering that it works with Wayland!

 

For KDE users: In your regular KDE session, you can start a nested Wayland KWin by doing

kwin_wayland path/to/aces

The launcher did not work for me like that so I had to launch it normally to update.

This did not work for me, as the game simply launched outside of the nested wayland session.

Share this post


Link to post
Share on other sites

Too bad that Gaijin did not test the game before pushing out the Vulkan version. 

 

Don't get me wrong, I really, REALLY like it, I have at least 80% more FPS on average in mimimum and average FPS on my RX480, so it is very GREAT and a very needed update and finally we see Vulkan support!

 

I'm also glad that the game has linux version unlike many other games, BUT they should have tested it on Xsession as well, because right now, if I want to play the game, I need to switch to Gnome from Cinnamon just to do it.

Edited by Balazs_hun
  • Like 1
medal

Share this post


Link to post
Share on other sites

I run  GNOME on my POP OS installation, but even after the Game update I have to use the workaround (starting the launcher directly). I hope that there is another Vulkan update that fixes this soon. Or do I have to make some adjustments to GNOME, to get rid of this issue?

Edited by _3FTL_Nighti69

Share this post


Link to post
Share on other sites

Same issue(s) here (Manjaro + Mint)

 

I get black blank screen after starting game via console.

But when i move the application to my other screen (press ALT+TAB  and right-click taskbar entry of game-> move to other screen), I am able to play fine.

 

- Screen 1: 4k 

- Screen2: FullHD

- Screen1 is set to default for game.

- Game is set to FullHD

 

(Primary/Secondary screen doesn't matter, i switched it already - same issues)

(I set Screen 1 to FullHD resolution, too - same issues)

 

 

medal medal medal medal

Share this post


Link to post
Share on other sites
46 minutes ago, KartuschenKurt said:

Same issue(s) here (Manjaro + Mint)

 

I get black blank screen after starting game via console.

But when i move the application to my other screen (press ALT+TAB  and right-click taskbar entry of game-> move to other screen), I am able to play fine.

 

 

 

Little hope that this would work also for workspaces, but unfortunately it does not.

Share this post


Link to post
Share on other sites
4 hours ago, Balazs_hun said:


I guess this is why we do not see any Ubuntu 20.04 users complaining here.

 

Ubuntu 20.04 here. Same problem with the launcher. I get the  PM:missing image crash.

 

For people not able to start the launcher via Steam have you tried launch option: env LD_PRELOAD="" %command% . It does work for me.

  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, orfi12 said:

 

Ubuntu 20.04 here. Same problem with the launcher. I get the  PM:missing image crash.

 

For people not able to start the launcher via Steam have you tried launch option: env LD_PRELOAD="" %command% . It does work for me.

Which kind of graphic  do you have, AMD or Nvidia?

 

i managed to start a gnome session on opensuse 15.2, launcher started, got into the hanger, could do test drives etc, started a battle but as soon as the battle started a got a fatal exception and the game crashed. (joining random battle was the last message on the screen) I have a Nvidia Geforce 1070. My wild guess its a combination wayland with nvidia problem

medal medal medal medal medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

For me it DOES work in plain xsession (log into tty6 with user, run startx -display :2 -- :2 vt6 which starts X with single xterm window in tty6 and from there I launch the game). That X session doesn't have any window manager or compositor, as far as I can tell, which may be the issue.

Unfortunately, doing this sometimes crashes the whole plasma desktop running on tty7.

medal medal

Share this post


Link to post
Share on other sites
On 16/11/2020 at 13:43, apemax said:

@derklempner,

 

Right, Not sure whats going on there then, When you start the launcher directly and the screen goes black the launcher is still working in the background, If you Alt+Tab to a different window the launcher should display, It only turns the screen black when in focus. So if you start the launcher, Alt+Tab away and let it finish, Then click the "Play" button it should start the game fine.

 

It doesn't. I run the "launcher" file, all screens go black, I ALT+TAB out, and the launcher window is an outline with whatever was under it showing inside the outline (i.e., desktop, other windows, etc.). If I click on it, all screens go black again. I downloaded the new launcher from the WT website and replaced mine, but the same thing happens. I can't launch the game with either the "launcher" or "aces" program, with the same results each time ("aces" showing the same errors I screenshot in an earlier post). If I don't click on the launcher window, it closes after about 10 seconds. The game and launcher simply won't run without dying.

 

I'm about at the end of my rope, I can't understand how it goes to working one day to stop working the next without any changes to my system other than game updates.

 

Oh, and here's the output when I run the launcher:

INTEL-MESA: warning: Haswell Vulkan support is incomplete
INTEL-MESA: warning: Haswell Vulkan support is incomplete
Segmentation fault (core dumped)

 

Edited by derklempner
medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

Derk..
 

I Installed Awesome Window Manager, switched to it. Updated software. Rebooted and now launcher and the game work as they did before the update.

Actually game runs smoother.

 

It is a window manager problem

 

medal

Share this post


Link to post
Share on other sites

I think the issue is with the display server and not with the window manager. 
I have Linux Mint 20 with Cinnamon, which use the Mutter Window Manager on xOrd display server. War Thunder doesn't work, black screen.

 

If I switch to a freshly installed Gnome desktop, which also uses Mutter WM but on Wayland insted of xOrg, War Thunder runs well.

 

There might be problem with other window managers, I don't know that, but in the case of Mutter, xOrg vs. Wayland is the issue.


---UPDATE---

I just quickly installed awsome window manager. It runs under x11/xOrg and War Thunder works well, additionally I also checked it in Gnome under xOrg and war thunder works there as well. 

So the issue really must be behind the window manager.

Edited by Balazs_hun
medal

Share this post


Link to post
Share on other sites

1st: When i try to launch the game from steam, nothing happens, the small "launching game" thing pops up for a split second and then nothing happens afterwards. It's also only since 2 days or such for me.
2nd: When i try to launch the game from the war thunder folder, using the "launcher" file, not the "launcher.exe", screens are black when focused on the window, and when i press play the screens still are black when focused on the window.
3rd: There isn't even a "launcher.exe" file in the folder, which i presume causes the 1st issue.
4th: When i have the game open but unfocused, the smoke and stuff seem all broken, in which they have basically no texture, just black boxes (view the attached picture)

 

Spoiler

 

 

System:

OS: Linux Mint 20 (Ulyana)      Kernel: 5.4.0-48-generic
CPU: Ryzen 5 3600

GPU: GTX 1050Ti

MB: B450 AORUS PRO

Edited by TagsonYT
spoiler the picture

Share this post


Link to post
Share on other sites

1. Start steam

2. Rename `~/.local/share/Steam/ubuntu12_64/gameoverlayrenderer.so` to `gameoverlayrenderer.so.disabled`

3. You may need to disable steam overlay in game settings

4. Launcher works now

 

Launcher coredumps can be obrained using coredumpctl command on systemd distros

Share this post


Link to post
Share on other sites
34 minutes ago, BLCRAFT said:

(rip login streak)

 

If you want to keep your login streak going without changing your compositor to wayland (to run the game for now):

 

open launcher;

press meta (typically windows) key - the one between Ctrl and Alt;

you will see the launcher;

click at the top on "Fullscreen" to bring up menu (the screen will go black again);

press the meta key again;

click on windowed;

you can repeat the step above to set a lower resolution than your usual;

open a terminal or any other window, make it small in size;

press Play in launcher (screen will go dark);

after a few moments, alt+tab to the small terminal window you have opened. You are now able to see war thunder launch in the background and control the mouse there;

after every click alt+tab into your small terminal;

 

login streak = saved

medal medal medal

Share this post


Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...