Jump to content

Dev Server 2.0.0.21 on Linux runs Vulkan natively :]


So, as the title says, Vulkan is enabled by default on the current Dev Server built for Linux! :biggrin:

 

So far it ran flawlessly for me, maxing out my refresh rate of 120hz in pretty much any situation on pretty much movie settings at 3440x1440 resolution.

Long awaited options like HQ TAA antialiasing are also available! No DLSS tho, despite me having a RTX 2700 Super atm. But I am not sure if any game would be able to support this feature on Linux :rolleyes:

 

Big thanks to @apemax for showing how to access the Dev Server on Linux, btw. Didn't know it was possible before.

 

EDIT: forgot to mention that there are also seemingly more effects, such as various sparks and such on non-pen,which I didn't notice with the current OpenGL client. If this makes it into the final build for 2.0.x it would truly be an amazing update for Linux users!

 

 

PS: Check the upper left corner of the game window on the screen shot for confirmation. I used Nvidias X Server Settings tool to show the currently used graphics API.

wt-dev-vulkan.png

Edited by KVNU
added some additional info
  • Like 4
  • Upvote 1
medal medal medal medal

Share this post


Link to post
Share on other sites

I yesterday tested it too, I made some vehicles test tanks and planes to check if the sparks particles hitting tanks were added.  I didn't saw them, neither any of the announced new explosions or muzzle flash, So  perhaps I didn't delete the regular warthunder folder, and it got mixed with the dev. Because at your screen capture the tank on fire seems new one style?

 

What I noticed was that the fps were as good as  when I play using vulkan now... that would explain that It was vulkan too actually @KVNU.   : D

 

 

 

 

Edited by BoNiu
  • Upvote 1
medal medal medal

Share this post


Link to post
Share on other sites

Thanks for the help toyeLinux. I will try a way to put Wayland on Ubuntu Mate then.

By the way, it's not a real black screen because I tried in windowed mode, with alt+tab i see the window but, when I click on it, I'm back to a black screen, really weird...

medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites
25 minutes ago, Pixtolero said:

Thanks for the help toyeLinux. I will try a way to put Wayland on Ubuntu Mate then.

By the way, it's not a real black screen because I tried in windowed mode, with alt+tab i see the window but, when I click on it, I'm back to a black screen, really weird...

i have exactly the same problem in KDE Xorg

medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

So, i've installed Fedora 33 Workstation, indeed, no more black screen.

With the dev server I can see the new hangar with the warning message because now the access is closed, but that's good, now I can see the game.

I tried the current stable version of WT by forcing vulkan via a command line, the game crashed sometimes, I was able to do two naval battles and an air battle. For tank battle, it's unplayable, the game crash every time before beginning the battle, I mean just after the screen with the map and the vehicles lineup. I hope this will be fixed with the major upadte.

  • Upvote 1
medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites
3 hours ago, Pixtolero said:

So, i've installed Fedora 33 Workstation, indeed, no more black screen.

With the dev server I can see the new hangar with the warning message because now the access is closed, but that's good, now I can see the game.

I tried the current stable version of WT by forcing vulkan via a command line, the game crashed sometimes, I was able to do two naval battles and an air battle. For tank battle, it's unplayable, the game crash every time before beginning the battle, I mean just after the screen with the map and the vehicles lineup. I hope this will be fixed with the major upadte.

yeah, fedora 33 use Wayland Gnome by defaut

 

The live version Vulkan is really worse than we seen in dev server

Edited by toyeLinux
medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

Wayland is not properly working with NVIDIA drivers atm. It is being worked on for Gnome and Plasma5 but MATE is a old spin of older gnome days so I doubt its received much wayland updates.

 

The issue people face with black screen on launch is %100 due to a compatibility with the compositor, you can't suspend the compositor, you need to KILL the compositor then the game will not have the issue.

 

There are many commands or alternative compositors you can mess with, I'd suggest for MATE to try and install+use the MUTTER compositor as that's what Gnome uses and WarThunder seems ok with that. 

 

The other issue I had was no working gamma/brighter control in-game for some reason. 

Edited by The_Riddick
  • Thanks 1
  • Upvote 1
medal medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

Wayland seems to work properly on Fedora Gnome, that's normal they switched to wayland since a while.

The problem is that wayland is not used officially by default by a lot of distributions just Fedora (RHEL obviously), Debian Gnome and some few, even Ubuntu doesn't used Wayland by default (they gived a try with 17.10 but they switched back).

I don't know what will happen with the next major update of WT for linux users who doesn't use Wayland or Gnome.

medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites
17 hours ago, Pixtolero said:

I don't know what will happen with the next major update of WT for linux users who doesn't use Wayland or Gnome.

 

They will be allowed to submit bug reports finally!

 

Really they should get the blackscreen on launch issue fixed with Plasma5 Kwin, it doesn't even look that serious because if you UNFOCUS the window it will render the game in the background and you can force it with kwin rules to keep that process UNFOCUSED yet still play. 


Quite literally a hairs throw away from working properly! 

Edited by The_Riddick
medal medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites
On 12/11/2020 at 22:53, The_Riddick said:

 

They will be allowed to submit bug reports finally!

 

Really they should get the blackscreen on launch issue fixed with Plasma5 Kwin, it doesn't even look that serious because if you UNFOCUS the window it will render the game in the background and you can force it with kwin rules to keep that process UNFOCUSED yet still play. 


Quite literally a hairs throw away from working properly! 

Well ever since Nvidia 4xx.xx driver there has been that orb around player controlled objects lighting up the world as you go around.  How are they going to fix that? and the one where you get killed by someone point blank looking right at them w/o seeing them because of spotting bug.

Edited by [email protected]
medal medal

Share this post


Link to post
Share on other sites

It seems that the incoming version wil bring some nasty surprises for the Nvidia/Plasma users :

On WT main branch the launcher now blanks the screen to black (unfocused it istill working fine). looks awfully like the vulkan bug = CONFIRMED  : "The launcher is now using Vulkan and unfortunately Nvidia does not support Vulkan for you GPU (GTX 570) so unfortunately there isn't much we can do."

Edited by ArcEnCiel_F_AMBV
UPDATE from the mod
medal medal medal medal

Share this post


Link to post
Share on other sites

I haven't played much with Vulkan release so do not know about the spotting or other render bugs at this time. The whole blackscreen thing is an annoying issue that puts me off even bothering most times. Also no brightness/gamma control is annoying. 

medal medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

@ArcEnCiel_F_AMBV,

 

The launcher black screen issue does not just affect Nvidia/Plasma users, The issue has been forwarded and is known. Regarding Vulkan, All Nvidia GPUs from GTX 600 series and newer will work fine, Unfortunately Nvidia don't support Vulkan for the GTX 500 series.

  • Like 1

Share this post


Link to post
Share on other sites

As of the new update the game forces you the vulkan renderer, causing black screens on KDE xorg and whatever else it affects. As Riddick pointed out above it actually displays properly if you force the game out of focus, even allowing me to get into test drive, but it doesn't accept keyboard inputs when unfocused (as expected) so it's unplayable.

Share this post


Link to post
Share on other sites

Hi Nexio_ I was testing Vulkan even before it was official and I know one stupid workaround. Press alt + F2 + shift to switch to command line and turning off the X server then navigate to Warthudner install directory (Something like .local/share/Steam/steamapps/War Thunder/linux64) and type startx ./aces. This will launch the game perfectly working, btw the performance is more than three times as much as before. If something does not work tell me I am on Manjaro 19 cinnamon (but that is not important really).

I also have some suspicion that this behaviour is something with the Linux AMDGPU driver itself, because the game run perfectly without any glitches. Also the fact it cannot be launched in Desktop enviroment seems to be some kind of problem with the Dekstop enviroment itself, because if you focus on  different window the game's window is rendering perfectly, but if you click into it black screen

  • Upvote 2

Share this post


Link to post
Share on other sites
9 minutes ago, mistrjirka said:

Hi Nexio_ I was testing Vulkan even before it was official and I know one stupid workaround. Press alt + F2 + shift to switch to command line and turning off the X server then navigate to Warthudner install directory (Something like .local/share/Steam/steamapps/War Thunder/linux64) and type startx ./aces. This will launch the game perfectly working, btw the performance is more than three times as much as before. If something does not work tell me I am on Manjaro 19 cinnamon (but that is not important really).

I also have some suspicion that this behaviour is something with the Linux AMDGPU driver itself, because the game run perfectly without any glitches. Also the fact it cannot be launched in Desktop enviroment seems to be some kind of problem with the Dekstop enviroment itself, because if you focus on  different window the game's window is rendering perfectly, but if you click into it black screen

 

Can confirm - this works (except for me switching to different TTY is ctrl+alt+f(1/2/3/4 etc)

 

However, this doesn't seem to enable EAC, so I got booted out of a game almost immediately and I had no sound in TTY2

Fortunately, this means that proper vulkan support is right around the corner (fingers crossed)

medal medal medal

Share this post


Link to post
Share on other sites
15 minutes ago, mistrjirka said:

Hi Nexio_ I was testing Vulkan even before it was official and I know one stupid workaround. Press alt + F2 + shift to switch to command line and turning off the X server then navigate to Warthudner install directory (Something like .local/share/Steam/steamapps/War Thunder/linux64) and type startx ./aces. This will launch the game perfectly working, btw the performance is more than three times as much as before. If something does not work tell me I am on Manjaro 19 cinnamon (but that is not important really).

I also have some suspicion that this behaviour is something with the Linux AMDGPU driver itself, because the game run perfectly without any glitches. Also the fact it cannot be launched in Desktop enviroment seems to be some kind of problem with the Dekstop enviroment itself, because if you focus on  different window the game's window is rendering perfectly, but if you click into it black screen

 

It cannot be AMDGPU - i have Mint 20 w/ Cinnamon on AMD Ryzen-5 3600X. And this AMD has no GPU on board, i'm on NVidia GTX1650 SUPER.

 

Game indeed starts when launched via "sudo startx ./aces", but does not recognises steam login then.

  • Confused 1

Share this post


Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...