Jump to content

CDK Carrier Spawn Problem / Question


After using the mission editor for a while, I've got a question about creating an airfield / spawn point on an aircraft carrier. 

 

The way I've attempted to do this up to this point:

1. Place the carrier on the map. Right now I'm using the USS Lexington.

2. Create 2 spherical zones for "airfield_start" and "airfield_end", at either end of the carrier. I've tried placing these both above and below the carrier's deck. 

3. Create a spherical zone to use as a spawn point, within the "airfield_start" spherical zone.

4. Add an F4F-3 as the player, and I've tried adding both slightly above and below the carrier deck.

5. Create a trigger that uses the "initMission" event along with the "addAirfield" action. The "addAirfield" action is set to use the two spherical zones as the runway start and end, and the spherical spawn zone as the spawn point. 

6. Use the "spawnOnAirfield" action to spawn the F4F-3, as the player, at the spherical zone labeled "airfield_start".

 

When I test this, I always start in the F4F-3 350m above the carrier deck where the spawn point was created, rather than stopped on the deck of the carrier. I'm basically using the same set of steps from the CDK tutorial, and it always works when I'm creating a mission where the aircraft is going to launch from an airfield on land. 

 

I'm hoping someone might be able to provide some help with this, or if someone has a mission where they've used a carrier as a starting point for the mission, so I could see the triggers / layout of spawn zones used. 

medal

Share this post


Link to post
Share on other sites
Quote

I'm basically using the same set of steps from the CDK tutorial

Which one?

 

As I assume it's for the multiplayer mission?

medal medal medal medal

Share this post


Link to post
Share on other sites

I'm basically using this one as a sort of "template":

I think this one is for single missions. 

 

I've been trying some different things, and when I use the action "missionMarkAsRespawnPoint" and select "carrier takeoff", the player at least starts on the deck of the carrier. But now it spawns the player at speed. 

 

I'm currently trying to use "UnitSetProperties" to see if it's possible to have the F4F-3 spawn at 0 speed, gear down and engine off. 

 

I noticed that when I set speed to 0, and then inevitably crash on the deck of the carrier, the following spawn is on the deck, gear down, engine running. 

medal

Share this post


Link to post
Share on other sites

This should work in singleplayer missions:

 

rn4K1tI.jpg

 

That's how it is done in Gaijin's test flight mission.

medal medal medal medal

Share this post


Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...