Best answer

Hi!

 

PS4 version 3.20 (1.99.1.39) was released today. It contains an updated sound engine. Our old sound system implementation, as we believe, was the main reason behind the majority of freezes and awkward sound behaviour (based on crash data and investigation of your multiple bug reports). Its performance degraded under prolonged or heavy loads causing all sorts of weird stuff, up to the point when the game could not carry out any further processing (simply put - the game would freeze).

 

This new version should fix most of these sound-related issues, if not all. We believe known issues (those that we were able to reproduce and therefore reliably verify) to be fixed. The statistical data already reported since the patch release on PS4 also confirms this so far but we will keep monitoring closely.

 

In case you still experience similar issues, please report. If the console invites you to send a crash report, please do so - it makes locating and fixing bugs much easier.

 

Sorry, it took us a while.

Share this post


Link to post
Share on other sites

Logged on today to play and re-spade tanks that needed to be spaded after the last big update and noticed that these problems have been going on since i started playing the game again after the last big update. This is on a standard Ps4 BTW, are these problems happening with everyone else or just me?

 

Note! watch from beginning to end to see how bad the game play deteriorates with issues

Edited by *Thunder0010
medal medal medal medal medal medal medal medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

I also have issues with game freezing and sound getting weird and then all battle sounds disappearing on my standard PS4. I reported these sound issues on 30 May. My main issues appeared when I was shooting long burst of machine gun fire, but the game didn't totally freeze.

But the last 3 days it I either get kicked out losing my vehicle or the battle ends and it doesn't seem to have anything to do with me using my machine guns. Below a video I attached to my bug report for the PS4.

 

medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

Yeah machine guns especially seem to overload the CPU. Mainly when there is quite a bit of smoke and stuff on screen. FPS then drops significantly even to the point the game locks up. When and if the game gets going again several sounds are missing. Sometime they come back, sometimes they don't. Either that or one sound will endlessly repeat in a loop.

 

It's a pretty bad bug because when it happens there's usually a lot of action going on and you become defenseless.

 

A good way to report it is to try to close the game when it is locked up. Sometimes that produces a crash and you can report it through Sony which will supply the devs a log file they can debug..

 

That's what I've done anyway.

Edited by *PureGT_Muzz
  • Thanks 1
medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

Its not just tanks i've had this issue with Naval is just as bad also the sound disappear also in that too. Air battle don't seem to have this issue at all as I have played 6 hours of them tonight and had no issues so its tanks and naval atm that have the problem -_- Thanks to you all for replying to this, was beginning to wonder if it was just me whom had these issues when no one was answering/adding to this topic. Oh does anyone who plays naval also get the ship is on fire alert stuck sometime all the way back to the hanger even after the match is over and then carrying on to the next match too??

  • Upvote 1
medal medal medal medal medal medal medal medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites
9 hours ago, *a-prost15 said:

I also have issues with game freezing and sound getting weird and then all battle sounds disappearing on my standard PS4. I reported these sound issues on 30 May. My main issues appeared when I was shooting long burst of machine gun fire, but the game didn't totally freeze.

But the last 3 days it I either get kicked out losing my vehicle or the battle ends and it doesn't seem to have anything to do with me using my machine guns.

I will add my video to the bug report also when I see it. I thought it would have been seen and confirmed by one of the tech mods by now or at least our PS4 Tech mod -_-

  • Thanks 1
medal medal medal medal medal medal medal medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

No reply on my bug report from a week ago. And my tanks keep getting killed by Gaijin. Ready to stop playing until this is resolved. I have games that don't crash regularly. :(

medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

I play in PC but yeah that freeze stuff happens and lasts like 3-4 seconds which can be fatal. Soundbug also happens but you can temporary fix it by looking at diff. direction or changing into different view (from commander to driver etc.) then hoping back to usual one. Maybe recheck game files or fiddle with audio options?

Edited by DemonCorps
just watched the vids
medal medal

Share this post


Link to post
Share on other sites
6 hours ago, F0Z [email protected] said:

Hmm, I can't say I have noticed this issue. What do you play on exactly? 

 

I'm using the xbox one X, but I will certainly look out and be more vigilant for this issue. 

 

Thanks for sharing. 

i play on different accounts with both Xbox One (wired ethernet) and PS4 (wifi)....the video the OP put up is exactly what happens...sound goes crazy then goes silent and youll notice towards the end of the video it kind of just freezes. I tryng to figure out a common denominator to when it happens to me and what i can pin it down to is that it happens when theres a lot of sound going on: cannon firing, machine guns going...never had this issue until the starfighters update.

 

 

on another issue: anyone else having an issue when in spectator mode? when im knocked out of battle and im scrolling to see what my teammates are doing, everything is going good until i get someone in a plane>>>firstly the plane POV is from some weird angle and secondly when you continue to the next person the graphics are all weird: for ex: looks like the tanks are just moving by levitating a few inches off the ground ( again this happens with both xbox and ps4)

Share this post


Link to post
Share on other sites

The first time I noticed this was in the April fools day event in the space ball turret things. Not a lot of stuff going on on screen but majorly fast machine gun / cannon fire for sustained periods.

 

It originally surfaced many years ago with the Kugelblitz AA making the sound "pop" on the Finland map.

 

Edited by *PureGT_Muzz
medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

I've seen Sony give refunds for this sort of stuff, for other games.

 

I think it's time everybody who have put money into WT joins up and makes a class-action complaint regarding a broken game and a developer that doesn't care.

 

Just look at the Strv103-0, it's still offered for sale and it's the opposite end of the Ka50, it gets nerfed ahistorically and BR adjusted upwards and repairboosted and only gets worse to control and play.

  • Thanks 1
medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

 Happened again last night on my Xbox account. Problem seems even more exaggerated on certain vehicles. For example, on my M4 when im using both types of the machine guns and cannon is firing it sends the game into sound overload and then freezes. Whats annoying is they say make a "bug report" but they dont even acknowledge it. Mine is still pending " moderator approval". Obviously theres an issue ...we cant all be imagining things here

Edited by *PAOK_SKG
missing info

Share this post


Link to post
Share on other sites

It happens to me in ground AB, I haven't played naval in a while.  It does seem to happen during a "sound overload" moment.  I was getting shelled, someone was firing at me and I was firing back at the same time.  Sound went dead but I was able to keep fighting then the screen froze and after about 30 seconds, everything pixelated into primary colors and I was booted back to the hanger.

20 minutes ago, *PAOK_SKG said:

Whats annoying is they say make a "bug report" but they dont even acknowledge it. Mine is still pending " moderator approval".

I know, I have never had a bug report approved by a moderator...

  • Upvote 1
medal medal medal medal medal

Share this post


Link to post
Share on other sites

What I get on a PS4 Pro is more like it survives the sound channel overload most of the times. Say Air RB, flying, destroying an object. Gone on since patch 1.95 and I may not have reported that mega-obvious bug. Bullet number five destroys the object, but the rest of the bullets, number 6 through 23, repeat the destruction sound of the object.

 

Still happens from time to time.

 

At least buildings going down in RBGF no longer means SECONDS PER FRAME.

 

They're making the other companies in the F2P business look like highly reputable developers striving to make happy players, be they payers or not.

 

Hang ooooooooooon that's what the other F2P developers are, even Crossout, Enlisted, Cuisine Royale, all Dagor engine games that run and look several times better than the mainline engine branch WT!

medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

Is their any way of replicating this so we know how it happens? If we work together as two communities and try to make it deliberately happen we can then post as one and hopefully get it fixed. 

 

I say this as I've played sim planes, RB ships and ground this last week and haven't seen any of the above happen once, so if we can find the trigger to make it happen we csn hopefully work on a fix together. 

  • Upvote 2
medal medal medal medal

Share this post


Link to post
Share on other sites
6 hours ago, F0Z [email protected] said:

Is their any way of replicating this so we know how it happens? If we work together as two communities and try to make it deliberately happen we can then post as one and hopefully get it fixed. 

 

I say this as I've played sim planes, RB ships and ground this last week and haven't seen any of the above happen once, so if we can find the trigger to make it happen we csn hopefully work on a fix together. 

 well i uploaded two videos of when this happened in my bug report thats still pending approval

  • Upvote 2

Share this post


Link to post
Share on other sites

A technical moderator is looking into the bug I reported and is trying to recreate it for the developers.

  • Thanks 1
  • Confused 1
medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.