Jump to content

Now we have better software to limit FPS: GOverlay (GUI for MangoHud)


I checked this https://github.com/doitsujin/dxvk/issues/399 but it fail to compile, maybe someone have better working "tool"?

 

EDIT:

Now we have better software to limit FPS: GOverlay (gui for MangoHud)

Its a Vulkan and OpenGL overlay for monitoring FPS, temperatures, CPU/GPU load and more.

 

Zrzut ekranu z 2020-12-28 18-48-13.png

Zrzut ekranu z 2020-12-28 18-51-48.png

 

Remember to click "Save" after you change something in GOverlay options.

 

This is the Mangohud discord: https://discord.gg/w5MzpBdc

Edited by tom34__Linux__
Discord server added, edited title

Share this post


Link to post
Share on other sites

I used this https://github.com/ycwan9/libstrangle but its not working for me, under OpenGL WT is running but under Vulkan not :wacko:.

 

Someone said here https://github.com/doitsujin/dxvk/issues/399 that libstrangle is not working with Vulkan (anymore) but i deluded that maybe it will be.... (sry for my english).

Edited by tom34__Linux__

Share this post


Link to post
Share on other sites

libstrangle use to work but it broke a while back. I think for some games it still works.  I did once ask the DXVK guy to add in the function for fps limiting but no idea if it got progress. Under windows you can just apply fps limiting anywhere by driver or riva tuner pretty easily.

 

The biggest issue is trying to explain to people why one might want fps limiting instead of vsync, because lots of people insist you just use vsync, but that can cause latency and similar issues.

 

There is also this thing which I think works but not the easiest method. https://github.com/pchome/VkGHL

https://github.com/pchome/VkGHL/releases/tag/v0.1

UPDATE: I was unable to get the vkghl method to work for me. Maybe I did something wrong.

 

What is needed is a tick box or option for it in Lutris/Steam to just apply it to specific games. (lutris has fps limiter but it doesn't appear to work as its greyed)

 

UPDATE: Libstrangle works, I simply make and make install it then added these into warthunder lutris launcher FPS=60 LD_PRELOAD=/usr/local/lib/libstrangle/lib64/libstrangle.so (use 32bit if 32bit game).  This should work for either wine or native, doesn't matter. It will work for OpenGL also.

 

 

Edited by The_Riddick
  • Upvote 1
medal medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

 

On 06/05/2019 at 03:11, The_Riddick said:

This should work for either wine or native, doesn't matter.

I using this command to run WT with Vulkan:

strangle 60 /media/tom/0481c97f-c487-4616-87d4-aac019640d7b/steam/steamapps/common/War\ Thunder/linux64/aces

After pressing Enter it hangs up in and i see this in console:

Setting breakpad minidump AppID = 236390
Steam_SetMinidumpSteamID:  Caching Steam ID:  765611998660876552 [API loaded no]

I checked "aces" process in System Monitor and i see that it have preloaded strangle:

 

Zrzut ekranu z 2019-05-06 22-04-52.png

Edited by tom34__Linux__

Share this post


Link to post
Share on other sites

Its not working with Lutris either.

On 06/05/2019 at 03:11, The_Riddick said:

(lutris has fps limiter but it doesn't appear to work as its greyed)

This option is not greyed but when i add 50 there its the same like in console, hangs up (i enabled terminal in Lutris options).

 

Weird because when i add  "FPS=60 LD_PRELOAD=/usr/local/lib/libstrangle/lib64/libstrangle.so" in Lutris Arguments game launch normally but without limited FPS...

 

I think libstrangle is not working with Vulkan for now, other people saying the same for example here https://steamcommunity.com/app/221410/discussions/0/1841314700702956454/#c1841314700705603521

 

Anyway thanks for help! :D

Edited by tom34__Linux__
Outdated

Share this post


Link to post
Share on other sites
On 08/05/2019 at 10:06, The_Riddick said:

I believe I compiled it myself so maybe that helps.

Like You i compiled it myself too.

 

By accident i found what was the problem... if steam is running in the background it hangs up, but when i unload steam, its working, game loads (i see login screen and limited FPS, all OK):

strangle 50 /media/tom/0481c97f-c487-4616-87d4-aac019640d7b/steam/steamapps/common/War\ Thunder/linux64/aces
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.
MicroProfile: Web server started on 127.0.0.1:4601
MicroProfile: Web server started on 192.168.0.109:4601

But why steam is the problem?

Edited by tom34__Linux__
Outdated

Share this post


Link to post
Share on other sites

steam uses esync, that can conflict with injected stuff.

Also keep in mind gaijin has limited the garage to 60fps, yes the game has a fps limiter built it, it seems, but disabled from options menu for use because, well gaijin...

medal medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites
On 10/05/2019 at 04:02, The_Riddick said:

In lutris or wine use, WINEESYNC=1  or 0 to disable.

 

Sounds like your making things real complicated for yourself, just use lutris.

I think You forgot that i not using WINE/PROTON, using native WT and now using Lutris to run WT. ;)

On 10/05/2019 at 07:48, chmooreck said:

nvidia-settings->OpenGl Settings-> Sync to VBlank

Works with vulkan too.

I have Radeon RX 570 4GB and Mesa free graphics drivers (stable padoka repo).

Edited by tom34__Linux__
Outdated

Share this post


Link to post
Share on other sites

I am using the native linux client (vulkan driver:RADV) on debian:

OpenGL vendor string: X.Org
OpenGL renderer string: AMD Radeon (TM) RX 480 Graphics (POLARIS10, DRM 3.30.0, 5.1.0, LLVM 9.0.0)

Just activated vsync in wt and it syncs to 60 (or 50) Hz without any problems.

Do you need some 'special' frequencies?

medal

Share this post


Link to post
Share on other sites

Yeah allot of us NVIDIA users still can't use the vulkan driver for this game, too many crashes (I heard its reduced lately). 

The only issue I have to put up with under wine is the false alarm background crashes which you can bypass, not sure what's causing it, can't really file a bug report since gaijin care not for steamplay or wine methods of running game. Tho I think I have received false alarms before under windows.. probably a nvidia thing.

medal medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

@tom34__Linux__,

 

i would really recommend to try the native vulkan renderer first, before tinkering with wine, DXVK and other additional layers.

RADV is very stable meanwhile and i can't remember when i had problems with wt the last time.

And yes, your link mainly addresses nvidia driver related problems.

 

Once you setup the experimental vulkan support for warthunder, you just have to keep care, that the 'launcher' don't revert your changes in 'config.blk'.

For the initial vulkan setup you will find a thread here in this subforum.

medal

Share this post


Link to post
Share on other sites
On 11/05/2019 at 17:24, amsel41 said:

i would really recommend to try the native vulkan renderer first, before tinkering with wine, DXVK and other additional layers.

I not want use WINE or PROTON only native redererer interest me ;)

On 11/05/2019 at 17:24, amsel41 said:

Once you setup the experimental vulkan support for warthunder, you just have to keep care, that the 'launcher' don't revert your changes in 'config.blk'.

For the initial vulkan setup you will find a thread here in this subforum.

O know bro, i know ;D no worries.

On 11/05/2019 at 20:31, Termy said:

Last time i tried there still was the blackscreen issue when you don't run it in its own x11-instance...not really convenient compared to activate proton in steam ;)

Blackscreen issue can be fixed, here how: https://steamcommunity.com/sharedfiles/filedetails/?id=1485296306

Working for me ;)

Or this solution, working for me too (this is better IMO):

 

Edited by tom34__Linux__
Outdated

Share this post


Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...