IStrykerI

Game Stutter Ryzen & 1080ti

Hi I've had repeated issues with stuttering for months now and I have not found a solution. Before I could run the game at 4k with no vsync. It was smooth and I was getting over 150fps. After either a WT update or Nvidia update (cant remember since it was a while ago) I started to suffer from microstuttering. That issue was solved by turning on adaptive v sync in the nvidia control panel. Now, I am getting stuttering every day. My fps is planted at 60 then it will drop to 30 or less for a split sec. This happens to varied degrees. Sometimes it will happen every 10-15s and sometimes it will happen every 30 or more sec. 

 

I have updated my drivers as well as tried previous drivers for the gpu

 

Specs:

 

AMD Ryzen 5 1600

GTX 1080ti

16gb ram

 

 

medal medal medal medal

Share this post


Link to post
Share on other sites

Sorry for the late reply. I've been busy with work. I don't have SSAA on. I managed to fix the stuttering issue that I had with adaptive v sync on but it is still suffering from microstuttering with it off. Dodo, I use the nvidia control panel setting because I can turn it off once the game is started. Once I turn it off, the fps is still locked but I no longer have the terrible input lag. I don't know why it works but it just does. 

medal medal medal medal

Share this post


Link to post
Share on other sites

Can you try with normal Vsync? Set in the NV control panel to Application controlled, and use the normal VSync in the WarThunder options.

 Please check if your motherboard supports the HPET option, the 1st gen RyZen's may have it enabled by default if its present. If yes - disable it and try again.

medal

Share this post


Link to post
Share on other sites
On 06/02/2019 at 14:32, Savanne said:

Please check if your motherboard supports the HPET option, the 1st gen RyZen's may have it enabled by default if its present. If yes - disable it and try again.

 

There was a performance issue with War Thunder after 1st gen Ryzen's release but if was fixed in the game (and later by AMD for game in general if my memory serve me right), and i wouldn't recommend do disable it because part of the game need it. If the situation improve with HPET off, it would be useful to file a bug report as the game (and Ryzen) are supposed to work fine with HPET. I have a 1st gen Ryzen with HPET on and no stuttering (and we have a couple of devs with Ryzen afaic), but bugs are weird creatures, it may be fine on a computer and not on another.

 

From experience, i would pay extra attention on memory stability with 1st gen Ryzen before trying anything else. Lastest motherboard bios updates help, but the first gen have trouble with some sticks (even with DOCP / automatic timings), leading to various degree of instability. I would recommend to let a full memory memtest run for at least 500%, as unstable memory can cause stuttering among other things.

  • Like 2

Share this post


Link to post
Share on other sites

Hey there, i have the same issues like the OP. My hardware is R5 2600X, 16gb ram and gf 1060gtx. when i tab in to the game and move my mouse a little bit my fps dropping pretty hard to 30 and being locked there. Tried everything you already wrote here but no changes :( 

medal medal medal

Share this post


Link to post
Share on other sites

Hm, one thing that came to my mind. Install Ryzen Master (i think its name was like that), and try doing "Game Mode", which effectively disables half the cores. If the issue is from the CPU, this could fix it probably.

medal

Share this post


Link to post
Share on other sites
59 minutes ago, Savanne said:

Hm, one thing that came to my mind. Install Ryzen Master (i think its name was like that), and try doing "Game Mode", which effectively disables half the cores. If the issue is from the CPU, this could fix it probably.

 

The gaming mode is only useful for some Threadripper, the Ryzens (gen 1 & 2) should work without issue with all cores activated.

 

On 09/02/2019 at 23:34, Sliptality said:

Hey there, i have the same issues like the OP. My hardware is R5 2600X, 16gb ram and gf 1060gtx. when i tab in to the game and move my mouse a little bit my fps dropping pretty hard to 30 and being locked there. Tried everything you already wrote here but no changes :( 


Make sure you have SSAA and vsync / adaptive sync / fast sync disabled (both in game and in the Nvidia panel), this is the most common cause for this issue.


If you can't fix it, file a bug report so the devs can have a look.

  • Like 1

Share this post


Link to post
Share on other sites
9 hours ago, Ouiche said:

 

The gaming mode is only useful for some Threadripper, the Ryzens (gen 1 & 2) should work without issue with all cores activated.

 


Make sure you have SSAA and vsync / adaptive sync / fast sync disabled (both in game and in the Nvidia panel), this is the most common cause for this issue.


If you can't fix it, file a bug report so the devs can have a look.


Yes, i am aware of that, its just a suggestion :)

medal

Share this post


Link to post
Share on other sites

Hello,

I'm currently having kinda the same problem, but in my case stuttering is caused by very fast fps drops.

 

Here's video that shows how it looks:

 

 

Solutions that I've tried so far: disabling HPET (helped with reducing the strength of drops), overclocking RAM for Ryzen's better performance, overclocking processor itself, disabling Nvidia Geforce overlay, lowering every setting in War Thunder, turning off g-sync (freesync) and v-sync, setting fps limit to 50 (helped with smaller drops, but didn't do much with bigger ones), disabling fps limit, moving the game to an SSD drive, updating every driver on my computer, updating bios, trying game in WIP mode, disabling services by ,,msconfig" command, changing screen refresh rate, changing screen mode (windowed, fullscreen etc.), reinstalling the game. Nothing fixed my problem entirely.

 

My system configuration:

Ryzen 5 1600

Rtx 2060

Corsair Vengeance LPX 2x4gb 3200Mhz (oc'ed)

Msi B350 PC MATE

 

I'm guessing that this can be caused by my Ryzen processor?

 

I'll atach .clog form matches in which I used profiler.

DxDiag (1).txt 2019_03_25_22_29_59__1124.clog

medal medal medal

Share this post


Link to post
Share on other sites
2 hours ago, Love_and_War said:

I'm currently having kinda the same problem

 

well... part of the problem (on your specific system) may be that pretty much only one cpu core is being 

used (core 12 being on 100% all the time while the other cores mostly idle) while your gpu is sitting at

60-70% usage (only) meaning the cpu is bottlenecking the gpu (which should not happen at all imho)

 

this behaviour has been experienced (and reported) by some other users as well (including intel Xeon

cpus so it's not AMD or Ryzen specific but some sort of multithreading issue). see on my little core i3

cpu (2/4 cores) the usage is not totally even spread between the cores either (that would be to much to

ask for anyway ^^) but at least there is some sort of distribution and no core goes up to 100% (ever).

 

now there have been some players reporting that manually disabling some of the cores kinda got them

a better distribution / multithreading (for whatever unknown reason oO) so this might be worth some 

testing... https://merabheja.com/set-affinity-for-an-application-on-windows-10/ (how to set core affinity)

 

though the results seem to have varied for the people trying this... as far as i remeber some players did

get the best results by just disabling the hyperthreaded (virtual) cores while others just disabled every-

thing above the 4th core (and even others reported the usage distibutions was almost even amongst

all cores when they just disabled all (but the first core), applied the change and then re-enbled all cores

again immediatly)... so you may have to try a few different ways (and maybe run the bechmark ingame

to see the results).

 

this by no means is the way it SHOULD work ofc ^^ but if it does it's actually a quite easy 'workaround'

(which unfortunately would have to be applied everytime the client is getting (re)started as the setting

wont be saved =/)

 

tl;dr

changing the core affinity for the aces.exe on the Windows Task manager may help on certain occasions.

medal medal medal

Share this post


Link to post
Share on other sites

Make sure to download chipset drivers for ur cpu from motherboard website drivers (as i couldn't get them from amd site, but it's available on motherboard site, at least for msi)
I ve never had any problem with stuttering like that on wt with my 5 1600.

After the chipset driver update a lot of games started to use multi threading a lot better and i mean like from 0 like on your video to normal balanced usage.

If you can't find it you may want to look for ryzen balanced power plan on google, i remember back then it was all aobut it.

I hope it can actually help you if you still haven't done it.

medal medal medal

Share this post


Link to post
Share on other sites

Some time ago I've tried disabling multithreading and resetting Processor Affinity. Results? Nothing changed.

But a couple minutes ago I've tried again, this time I've disabled "Processor 0" and it seems that now stutter isn't occurring as often as before, but it's still pretty noticeable.

 

I've updated my chipset drivers twice and tried AMD Balanced plan as well as High performance and didn't notice any difference.

 

It seems that War Thunder is really heavily one-core based, cause' I hadn't got any problems in other games: Rainbow Six Siege, For Honor, Battlefield 4 and Overwatch. I had terrible stutter in Battlefield 1 - fixed by using Intelligent Standby list cleaner, but still sometimes got slight drops.

 

I really appreciate your help, but still, I'd be really grateful for any other solutions. I've been searching every internet forum trying to find a temporary fix for these drops since February with no results.

 

Edit: I've tried some cases such as: only processors above 4, only processors above 4 and without 0, only processors above 4 and without 0 but I set it back to all processors, and it seems some of that solutions weaker the stutter but none actually fixes the problem :(  (tried with AMD Balanced and High performance and actually high performance helps to reduce the stutter greatly)

 

Edit #2: That's got to be a problem with Ryzen/motherboard, because today I've tried War Thunder on my brother's PC, which is almost the same as mine and the issues isn't gone even there.

Edited by Love_and_War
medal medal medal

Share this post


Link to post
Share on other sites

What Frequency is your ram running at?  Ryzen defaults to 2133 on most memory if you don't set a higher speed or activate the xmp profile.  What motherboard model do you have?  Have you kept the UEFI/BIOS up to date?  Are you running a single 16GB dimm instead of 2x 8gb dimm's?

 

If possible, please upload a current dxdiag.txt to your post, so we can check it out and look for issues.  I'm running an R7 1700x on a x370 motherboard with 16GB Ram, and have no stuttering issues myself.

Share this post


Link to post
Share on other sites
On 01/04/2019 at 16:50, Conraire said:

What Frequency is your ram running at?  Ryzen defaults to 2133 on most memory if you don't set a higher speed or activate the xmp profile.  What motherboard model do you have?  Have you kept the UEFI/BIOS up to date?  Are you running a single 16GB dimm instead of 2x 8gb dimm's?

 

If possible, please upload a current dxdiag.txt to your post, so we can check it out and look for issues.  I'm running an R7 1700x on a x370 motherboard with 16GB Ram, and have no stuttering issues myself.

I'll try to do that when I get home.

 

Edit:

Ryzen 5 1600 3.8ghz

2x 8gb ram OC 3200

Asrock AB350 Pro4

EVGA 1080ti

DxDiag.txt

Edited by SgtStryker
medal medal medal medal

Share this post


Link to post
Share on other sites

I have the same problem since one of the updates this week.

I'm using G-Sync with G-Sync compatible Freesync monitor, V-Sync off and Fps-limiter @ 142fps to stay in the G-Sync range.

All was fine until this week.

(Last WT-Update used before stutter was the one right before April Fools).

 

Specs:
Intel Core i5 3570K @4GHz

16GB Ram

RTX 2070

 

My last core is used 100% permanently, the other cores nearly do nothing. Never had this before.

The fps are generally stable but with spikes to 1fps inbetween.

 

Update: It happens when there's a noticeable packet loss, which btw happens to me every match, cause the peering of my provider (German Telekom) has gotten worse since two years.

Edited by McGeiver
medal medal medal medal medal medal

Share this post


Link to post
Share on other sites
On 03/04/2019 at 16:41, SgtStryker said:

I'll try to do that when I get home.

 

Edit:

Ryzen 5 1600 3.8ghz

2x 8gb ram OC 3200

Asrock AB350 Pro4

EVGA 1080ti

DxDiag.txt 79 kB · 1 download

 

I don't see much wrong with your system.  Like someone else said, it could be thermal throttling due to the OC on the CPU, depending on what cpu cooler you have.  I don't OC my 1700x because it boosts to 3.9Ghz on its own with my H100i cooler.  As far as driver issues, your realtek sound drivers are fairly out of date.  And on the subject of bios/uefi, that is fairly out of date on your board.  I want to tell you to update the bios, but there is always the chance you'll lose your cpu Overclock and Ram speed if you do.  ASRocks memory support in their bios's has been iffy, even on my X370 Fatality Gaming Pro for, Ryzen CPU's.  

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.