Jump to content

Freeze when starting in fullscreen mode


Hi,

The game works very well in windowed mode but when I try to start in fullscreenmode, after starting the game my screen freeze on the launcher image and i must reboot to use my computer again.

My config is War Thunder on Steam on Linux

 

CPU:       6 core AMD Ryzen 5 2600X Six-Core (-MT-MCP-) cache: 3072 KB
           clock speeds: max: 4099 MHz 1: 3479 MHz 2: 3881 MHz 3: 4089 MHz
           4: 3737 MHz 5: 3713 MHz 6: 3722 MHz 7: 3852 MHz 8: 3354 MHz
           9: 4098 MHz 10: 4099 MHz 11: 4099 MHz 12: 4094 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Baffin [Radeon RX 460/560D / Pro 450/455/460/560]
           Display Server: x11 (X.Org 1.20.3 ) driver: amdgpu
           Resolution: [email protected], [email protected]
           OpenGL: renderer: Radeon RX 560 Series (POLARIS11, DRM 3.27.0, 4.19.5-calculate, LLVM 6.0.1)
           version: 4.5 Mesa 18.2.5

Can you help me ?

Share this post


Link to post
Share on other sites

I have similar problem with wine + dxvk. In previous versions everything worked perfectly. WT with update 1.85, shortly after login my GPU (GTX 1070 415.25) freezes and monitor goes black. Now I can't play WarThunder in any renderer:

- Native OpenGL: Black Texture Bug,

- Vulkan with Compiz compositor: War Thunder crashes at start,

- Wine + DXVK: As above,

This is pathetic - for couple months devs can't fix native client for new drivers and blame Nvidia. Other OpenGL games works fine with 400 drivers series. Even if nvidia implementation of OpenGL changed slighty, developer team should adjust client renderer in day or two (my guess is that Gaijin don't have any experienced Linux or OpenGL developer anymore).

With such poor developement of Linux Client I think that Gaijin should drop official support of Linux version. Also for linux players they should ensure that game works fine with WIne + DXVK and everyone would be happy.

medal medal

Share this post


Link to post
Share on other sites

Yeah, Wine is broken for me as well.

 

Good thing I have a copy of Windows to get me through these events.  160 FPS on maximum settings......

 

Linux client is literal clown shoes.  It sure is easier to blame it on NVIDIA though!

Edited by vivnet
medal medal medal medal medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

Hello,

i don't use NVidia but AMD (with opensource drivers because there are very good, not as nouveau on NVidia ;D)

On Linux, I use native client in Steam, not Wine.

 

Share this post


Link to post
Share on other sites
On 23/12/2018 at 22:51, vivnet said:

Report it as a bug.

Sorry, i can only post 1 message per day (i don't know why...)

I reported the bug here : 

But mu message is pending approval since December 7th !!!!!!!!

Share this post


Link to post
Share on other sites

@AdrienD, i am using mesa opensource driver too and it works really good meanwhile.

 

But i am building mesa from git-source locally and have always the latest features, performance and fixes this way.

 

Did you try the experimental vulkan renderer (RADV)?

If not, just create a file named 'pkg_vulkan.rq2' in '..\WarThunder\content\' folder and start the launcher to load some shader resources.

After that, edit 'config.blk', change driver:t="auto" -> driver:t="vulkan".

Start warthunder via command line (./aces), because launcher would revert your 'config.blk' changes otherwise.

Edited by amsel41
medal

Share this post


Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...