Spu7nik

SSAA massive GPU usage?

Not a fan of new TAA, make everything fuzzy, was gonna use SSAA just like I did in 1.75, but now same settings take up 100% of my 1080.... not sure if it's bugged, but something doesn't seem right. Before I turn SSAA on my gpu usage is 35-40%, after I turn SSAA on usage is 100%......

 

Also does that look right to you?

 

 

Inked20180315213959_1_LI.jpg

Edited by Spu7nik
medal medal

Share this post


Link to post
Share on other sites

Pretty sure SSAA is new to 1.77.

It would be expected to see a drop in performance with ssaa on as it essentially renders the game in a much higher res (up to 4x in warthunder) and then scales this down to native resolution whilst averaging the values of nearby pixels. Running fine with SSAAx4 on my RX480 but thats with a native res of 1080p, not sure why you'd have such low performance with a 1080. Try updating drivers?

Edited by Raichor
  • Upvote 1
medal medal

Share this post


Link to post
Share on other sites

SSAA 4x is 4x the resolution. SSAA DID NOT EXIST in the Launcher before 1.77, only in the config which you had to manually edit out of game and change read settings. 

 

If you have a 1080p monitor, 4x SSAA is equivalant of running the game in 4k. Your running 1440p, of course your graphic card will be screaming with SSAA 4x. That's almost double the pixels of 4k. 

 

The entire reason Gaijin never put SSAA in the launcher before 1.77 is exactly because people would turn it on then come on the forums complaining that something is wrong. Looks like they were right lol.

 

Edited by DaffanZ
lol
  • Thanks 3
  • Upvote 2
medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites
Quote

 

Ok thank for your input fellas, the only question I have now, is why didn't they keep the 1.75 version of AA? Is there any way of turning it on, maybe in config file? BTTW i'm running 1440p
 

Edited by Spu7nik
medal medal

Share this post


Link to post
Share on other sites
1 hour ago, Spu7nik said:

Ok thank for your input fellas, the only question I have now, is why didn't they keep the 1.75 version of AA? Is there any way of turning it on, maybe in config file? BTTW i'm running 1440p
 

Because the old version of AA did nothing. It simply did not work. 

 

Editing your config.blk to have Backgroundscale at 1.2-1.5 is vastly superior, it's the equivalent of 2x SSAA. 

 

 

Edited by DaffanZ
  • Like 2
medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites
7 hours ago, sgtlongbow said:

just use hq txaa and your performance should be close to what it was pre 1.77

I would never use TXAA or FXAA. I tryed it and it looks awefull. The whole picture is one big mashup and the image is extremely soft and I just don't recognize anything anymore. It is like to be on drugs and all is warm and smooth. :\

For me, i would prefer SSAA 2x or no AA but never postprocessing AA like TXAA. 

  • Like 1
medal medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites
5 minutes ago, Rawday said:

I would never use TXAA or FXAA. I tryed it and it looks awefull. The whole picture is one big mashup and the image is extremely soft and I just don't recognize anything anymore. It is like to be on drugs and all is warm and smooth. :\

For me, i would prefer SSAA 2x or no AA but never postprocessing AA like TXAA. 

Simple fix. Use ingame sharpness when using TXAA. 

 

TAA is different to TXAA btw. 

Edited by DaffanZ
  • Upvote 1
medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

Ingame sharpness? Is it an option in the graphics-setting? 

 

And of course TXAA is different to TAA. I though WT uses TxAA. Sorry. :)

 

But i tryed with Backroundscale 1.5 and for me its the perfect solution. Not as hungry as SSAA4x but much more better imagequality. Before i had backgroundscale=2 and the game looks great, but FPS goes down to 40FPS. Not playable. 

Edited by Rawday
  • Like 2
medal medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

Using 4x SSAA while using the common 1080p resolution of 1920*1080 means your graphics card has to render the images in the resolution 3840*2160 (4K). That's why your graphics card is so busy when activating the 4xSSAA option.

 

Radeon users can achieve this effect easily by activating VSR (virtual super resolution) in their drivers menue. This unlocks higher resolutions than your monitor can handle while the graphics card renders the game internal in this resolution and then downscales it back to the monitor resolution again.

Nvidia has somethingsimiliar in their drivers menue but I forgot what its name was

Edited by Rainbowprincess
medal medal medal medal medal

Share this post


Link to post
Share on other sites

As it was said in that thread : SSAA do use a massive amount of power. It's not a bug, it's rendering the game at 4 time the screen resolution and as a result, it's extremely heavy on the performances. It's there for hardware enthusiasts with top of the line GPU, basically.

 

TAA (or HQ TAA) is the best quality / performance ratio you can get for mid/high-end gpu.

Share this post


Link to post
Share on other sites
9 hours ago, DaffanZ said:

Because the old version of AA did nothing. It simply did not work. 

 

Editing your config.blk to have Backgroundscale at 1.2-1.5 is vastly superior, it's the equivalent of 2x SSAA. 

 

 

Original AA worked perfect for me, I had no jagged edges without making game look soft and fuzzy, with my gpu usage stayed within 50% all times, removing it was a very bad move...

 

I tried editing config file like you said, but I does nothing and bumps Backgroundscale to 1...

Edited by Spu7nik
medal medal

Share this post


Link to post
Share on other sites
23 minutes ago, Crawfield said:

You have to edit it and then write-protect the config file.

Otherwise the launcher will reset it.

How do I do that?

medal medal

Share this post


Link to post
Share on other sites

Perhaps there's issue with Nvidia cards/drivers?

I'm running 980Ti and after turning on x4 SSAA performance dropped for as well. FPS was around 45-50 and game felt rather sluggish.

 

Simply wondering this as one user mentioned that he runs x4 SSAA fine with his RX480.

medal

Share this post


Link to post
Share on other sites
46 minutes ago, MOBB said:

I set NVidia control panel msaa to x2 at 3440x 1440.  no jaggies or blurring...

For some reason anything I set in NV control panel for WT just does not take effect, I set it, go in the game and there's still jagged edges....

medal medal

Share this post


Link to post
Share on other sites

actually, control panel doesn't work anymore... weird...and ssaa is making my water cooled 1080ti go from a gsync 120 down to around 80.  I would use the config file solution, why no 2x ssaa?....

  • Like 1
medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites
4 hours ago, Ouiche said:

As it was said in that thread : SSAA do use a massive amount of power. It's not a bug, it's rendering the game at 4 time the screen resolution and as a result, it's extremely heavy on the performances. It's there for hardware enthusiasts with top of the line GPU, basically.

 

TAA (or HQ TAA) is the best quality / performance ratio you can get for mid/high-end gpu.

2 time the screen resolution, not 4 times :)

medal medal medal medal medal

Share this post


Link to post
Share on other sites
1 hour ago, Rainbowprincess said:

2 time the screen resolution, not 4 times :)

 

4x the pixels :)

 

3 hours ago, *ph00ktastc said:

Perhaps there's issue with Nvidia cards/drivers?

I'm running 980Ti and after turning on x4 SSAA performance dropped for as well. FPS was around 45-50 and game felt rather sluggish.

 

Simply wondering this as one user mentioned that he runs x4 SSAA fine with his RX480.

 

1080p with 4x SSAA = 4k

1440p with 4x SSAA = 5k

Edited by DaffanZ
medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

I actually love this addition, lost 60FPS, but I am still above 60FPS anyway on Ultra settings, game is so nice and smooth and I actually see better than before. 
Thank you for this, Gaijin.

 

GTX1070 8GB

i5 6600K

medal medal medal medal medal

Share this post


Link to post
Share on other sites

A comparison of TAA on and SSAA off, but background scale at 1.5. The image is razor sharp and I am driving with Vsync at 60FPS throughout (On the Image i had 90FPS, bc i switched vsync on later). 
Of course the FPS are higher at TAA, but the image is simply too soft. On FullHD I don't recognize any more tanks in the distance, because they are blurred by the soft focus. 

But apart from that, the new engine looks fantastic. 

 

Backgroundscale at 1.5:

Spoiler

20180316205333_1.thumb.jpg.48b7b5b30e936

 

TAA

Spoiler

20180315193543_1.thumb.jpg.c9b7ec859ff7e

 

Edited by Rawday
  • Upvote 1
medal medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.