SuperProtoMan

How to Fix High Ping/Planes going Insane (probably)

Hello!

I am SuperProtoMan. I mad the actual War Thunder account today because I was having problems with this and wanted to give a possible solution to this predicament. You can also watch the video. It is somewhat low quality, as  There is no sound, so I recommend watching it with the directions.

 

Important information:

This is a Windows (10) guide, not sure what to do on Mac

Most people blame the servers. This is NOT always the problem. It could be a bad WiFi/Ethernet signal.

This was making my plane move around in ways it is not supposed to, video attatched.

 

Step 1: Where is the problem?

First, you have to figure out who's fault it really is. First, load another game with servers that shows ping/latency (I used Minecraft), and go on to one or two servers there. If those are also laggy, then the problem is not with War Thunder. Next, do a download speed test. At least for me, the problem did not appear, but it doesn't hurt to check.

Results from this step:

  • If nothing else lags, it is War Thunder's servers and I am afraid there is really nothing you can do about it.
  • If other things lag, and your download speed is fine, go to step 2.
  • If your download speed is horrible (below 0.75 MBps), then most likely you should complain to your internet provider, but read on to be sure.

Step 2: Fixing the problem (hopefully)

Ok! It is narrowed down to your computer or the Internet you have. Both of those are in your power to change.

First,  there are some questions you need to ask yourself.

1: Am I using Windows 10?

1.5: Did I just install Windows 10? (0-2 weeks ago)

2: Is there anything obvious taking up bandwidth? (1GB downloads, etc)

 

Next, you need to find out what may be taking up bandwidth. Close all your programs, including War Thunder. Now try it again. If it works, load up the programs you had one by one and figure out what you had on that destroyed War Thunder's Internet connection.

If that doesn't work, it may be something in the background. Pull up Task Manager (Ctrl+Alt+Del) or Start menu. Now click on more details. It should be a medium-size panel displaying all kinds of information. On the top of it, click the "Performance" tab. Then go to the bottom and hit "Open Resource Monitor." Another window should pop up. Now, in this new window, hit "Network". War Thunder should be OPEN now. It will show up as "aces.exe" or something along those lines. Now, on the first table, is there anything above the aces.exe one? If there is, it is probably taking bandwidth many orders of magnitude more than War Thunder's aces.exe. You can tell by the total B/sec  on the top of it. If you want to be safe, research it and make sure it is OK to end the process, but I suggest just right-clicking on it and hitting the "End Process" button. Once aces.exe is on the top, you should be good to go!

 

Tell me if it works!

Post below: Did this solve your problem? Do you have anything to add? If you have another solution, please post it and I may add it.

pingfixer.mp4

medal medal medal medal

Share this post


Link to post
Share on other sites

Another thing to note is open up your task manager, shortcut is Ctrl+Shift+Esc (if you are on a windows computer). If not done already click on "More details" and look under Processes tab. Click on the network column until a down arrow appears, this indicates that the highest value will show up on the top of the list. From there you can see what program/services is utilizing your network.

medal medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

I was going to say the same thing as @PlzDontKillDave but I didn't know that shortcut! I usually right click on the windows icon bottom left. BUt the majority of the time is something is using your bandwidth. If your FPS was low it would be computer performance mostly.

Share this post


Link to post
Share on other sites

i've been having these problems lately and contacted Gaijin and got a response.  so i did some upgrades as they requested and had much better game play.  (a good ping for me is 50-60)  about a week went by and here we go again.  i start a game around 54 and it never fails, about 4 minutes in im around 150-220.  from there i've been at 999.  cant fly for crap, cant hit a damn thing.  its frustrating as hell because its a fun game but this isnt an issue with my computer or internet, its their servers.  i normally dont even bother to play in the evenings because it is worse for me then.  this morning i noticed it got bad so i came here to vent lol.

Share this post


Link to post
Share on other sites
On ‎30‎/‎06‎/‎2018 at 14:31, TIE_Pilot491 said:

i've been having these problems lately and contacted Gaijin and got a response.  so i did some upgrades as they requested and had much better game play.  (a good ping for me is 50-60)  about a week went by and here we go again.  i start a game around 54 and it never fails, about 4 minutes in im around 150-220.  from there i've been at 999.  cant fly for crap, cant hit a damn thing.  its frustrating as hell because its a fun game but this isnt an issue with my computer or internet, its their servers.  i normally dont even bother to play in the evenings because it is worse for me then.  this morning i noticed it got bad so i came here to vent lol.

does youre game lag? I will be turing and then it jumps my game around and some times my plane flys fine but the enemy goes everywhere 

I also have my game jump so its like a delay then it jusps and so on but then again I think this problem is down to my village having added 100 new houses right near me as well

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.