I can't play WT after the 22 June 2017 update (1.69.2.75).  The launcher comes up OK.  But when I press the red "PLAY" button in the lower right, the screen goes black and I can't log-in to my account.  I'm using a Gaijin account, not a STEAM account.  I've performed a file check/analysis = OK.  Windowed mode and lower res show a "(Not Responding)" warning on the titlebar at top.  I updated my videocard driver to no effect.  I've looked at the excellent troubleshooting tips on the forum and nothing works so far.  Perhaps I'm going about it all wrong.  What logs should I include?  (dxdiag?  trouble logs?  et al.)  Thanks for any further advice.

System Specs:

Acer Aspire T3-710

Win10 Home 64-bit

Intel i5-6400 CPU

8GB Ram

Intel HD 530 integrated graphics (driver 21.20.16.4550 updated yesterday)

Edited by Buzz73
BSOD/BlkSOD typo

Share this post


Link to post
Share on other sites

You're playing war thunder with your desktop resolution, I am correct?

 

And correct me if I'm wrong, shouldn't a BSOD have a blue screen associated with it? ;)

 

That sounds/looks like your video card is crashing, that or its drivers are anyway.

 

 

 

Open Event Viewer.
Open "Windows Logs" from the sidebar

Open "System" from the sidebar.

 

Find errors/warning from right before/around the crash. What do they say?

 

medal medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

Thanks for the correction...  my mistake.  Changed it to Black Screen!  I checked your kind suggestion regarding the Event Viewer, nothing listed after I tried to start the game.  I haven't been able to use the desktop resolution in Fullscreen since one of the April updates.  Kept freezing explorer.exe when I would exit the game.  I've been running it in Windowed mode at one resolution lower since then with no issues until now.  I will try the desktop resolution Fullscreen again and report back.  Thanks for the help so far!

Edited by Buzz73
Semantics error

Share this post


Link to post
Share on other sites

Let's take a couple of steps back, your PC isn't crashing? The game just has a blackscreen and doesn't respond, but you can still continue to use the PC?

Edited by Hopit
medal medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

Simply, yes the game just has a blackscreen and won't repond.  Not a crash, more like a freeze... of sorts.  :008:  Ctrl-Alt-Del will respond and get me to task manager to reboot.  But I can't select WT to force a shutdown in task manager because the mouse won't work.  But the mouse will work to select reboot.  On the desktop, the cursor is invisible and goes behind windows until I click on an empty place on the desktop, then the cursor will be visible.  In fullscreen mode my only option is to reboot via task manager.  If in windowed mode, I can close WT from the desktop.  Clear as mud, right?  :crazy:

Share this post


Link to post
Share on other sites

Oooh...

From your topic title having BSOD in it (and now blksod) I was imagining your whole PC was crashing (as that's when BSOD happens)

 

 

Do you have Avast Antivirus?

 

 

 

 

medal medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

Sorry about that.  Finally figured out how to correct the topic title (click & hold, right?)  To answer your question, no, I don't have Avast.  I have ZoneAlarm AV+Firewall.  I have all firewall whitelist exceptions, that I can find, enabled for both gaijin and WT.  I also tried ZoneAlarm game mode which didn't work... same black screen.

Share this post


Link to post
Share on other sites

Try running the game with DirectX 9 if you have option for it, if not try OpenGL (Launcher -> Gear Icon -> Render)

Edited by Hopit
medal medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

I tried Dx9 via WinXP SP3 compatibility mode.  No change.  I also tried OpenGL via the render option.  No change.  Menu bar still reads "War Thunder (OpenGL3, 64bit) (Not Responding)".  Thank you for all the great suggestions so far. 

Share this post


Link to post
Share on other sites

Hi Hopit,

     What are your thoughts regarding an upgrade to a dedicated videocard (e.g. nVidia GTX1050).  In your opinion, would it improved these issues?  The integrated Intel video seems to have constant issues with games.

Share this post


Link to post
Share on other sites

Try re-installing your drivers

 

 

 

 

And For this

1 minute ago, Buzz73 said:

Hi Hopit,

     What are your thoughts regarding an upgrade to a dedicated videocard (e.g. nVidia GTX1050).  In your opinion, would it improved these issues?  The integrated Intel video seems to have constant issues with games.

 

I would only use an integrated GPU when/if my dedicated GPU broke, and only long enough for me to get my GTX 770 from upstairs. (Integrated aren't really for gaming...)

medal medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

could you maybe upload your latest launcher log (located in the ..\War Thunder\.launcher_log\  folder) and

game log (*clog file located in the ..\War Thunder\.game_logs\  folder) ? i assume there aren't any crash

dumps (files with a *.dmp file extension) in the game logs folder since the game isn't actually crashing ?!

 

while i dont really think that it'll make any difference you may still want to check if the 32bit client is running

(assuming that by default the 64bit client should be running on your system) by switching the 64bit option

in the advanced settings (gear icon next to the graphics presets) from auto to off...

 

you could also check the Work in Progress (WiP) client by ticking the WiP tickbox in the lower right corner

of the launcher (just above the play button)

 

and just to make sure it's not an issue with the firewall (which i also dont really think it is but hey better save

than sorry ^^) you could remove and redo the firewall settings for the aces.exe (and make sure you either 

got the correct one (64bit client or 32bit client) or both added to the firewall)

medal medal medal

Share this post


Link to post
Share on other sites

Thanks for the suggestions and the kind reply, relliK.  I've enclosed both launcher logs and game logs per your request.  I didn't see any .dmp files.  I tried the 32bit client suggestion, but it didn't have any effect.  I've already tried the WIP client, to no effect.  I've also rechecked the firewall issues, but will remove and redo per your suggestion.  I will get back to you with the results.  Thanks again to both Hopit and relliK for your help and patience.

2017_06_25_09_50_17__5144.clog

2017_06_02_09_30_51__3924.txt

Share this post


Link to post
Share on other sites

I removed and redid aces.exe (32-bit & 64-bit) in the firewall, per your suggestion.  No effect, unfortunately.  Also rechecked that gaijin.net and the warthunder launcher is also whitelisted in both ZoneAlarm firewall and the Win10 firewall.  Any further ideas?

Share this post


Link to post
Share on other sites

I upgraded to a dedicated videocard (GTX 1050 Ti SSC 4GB), latest nVidia drivers, et al.  Still a black screen when I hit "Play".  I finally sent in a troubleticket request to Gaijin.  I will let you know what I find out from them.  Thanks again to Hopit and relliK for your excellent advice so far. 

Share this post


Link to post
Share on other sites

thing is that the connections to the War Thunder / Gaijin servers are timing out (or they are getting blocked)

unfortunately however there is no reason given =/ not even a hint... so it may be difficult to find the real cause.

 

hmm... while the launcher seems to run it definitely also needs quite long to connect to the servers or retrieve

data from the server...

 

5.41 [D]  $06 http://yupmaster.gaijinent.com/launcher/cdn_conf.php loaded with HTTP status code 200 (3.703 seconds, 6236 bytes answer):

5.71 [D]  $0A http://warthunder.com/news3-en.html loaded with HTTP status code 200 (3.641 seconds, 3555 bytes answer):

 

i mean 3.7 seconds to fetch 6236bytes is.... ummm... quite long ^^ even if you are on the other side of the globe

it shouldn't take that long...

 

did you already restart your router ? you are on a home network i assume not a college or university network !?

 

one more thing (that most likely wont do anything to this problem but since it doesn't take much time it may be

worth a try) - your game is installed in C:\Users\unknown\AppData\Local\WarThunder - since the user profile 

folders are system folder there may be some special restrictions in place. you could try moving or copying the

while War Thunder folder to a different location like c:\War Thunder\ or c:\games\War Thunder\ etc and then

try again (though you will have to add new firewall rules for the new location first)

 

 

medal medal medal

Share this post


Link to post
Share on other sites

Thanks for the suggestions, rellik.  To answer your questions:

1.  Yes, I have restarted my router several times as well as my computer.

2.  I'm on a home network, running at 3Mbps

3.  I copied the War Thunder folder, per your suggestion, to C:\War Thunder.  Double-checked all firewall rules, etc.  Same issue. 

4.  I also re-downloaded the launcher, to no effect.

5.  I noticed that the news feed is now blank on the launcher, as of today.

Share this post


Link to post
Share on other sites

I finally got it to run at reduced textures.  Here is what I did:  (Items with a *** seem to have made the most difference.)

1.  Re-installed WT, this time through STEAM.  I noticed that the Steam version is 17.2 GB in size while the Gaijin version is 16.2 GB.
2.  Disabled Win10 firewall initially, and shown hidden files.
3.  Launcher updated several times.
4.  Several UAC pop ups that I "OK'd"
5.  Enabled ZoneAlarm firewall permits for both public and private connections
***6.  Enabled Microsoft Catalog Utilization.  (Launcher finally worked when I hit "play" and I could log-in.  Had a connection error xxxxx....007.  Game wouldn't connect.) :008:
***7.  Rechecked 'seed after download', 'use DHT', 'use peer exchange', 'use tracker exchange' (Game ran via aces.exe, wouldn't run if I used Launcher.) :)
***8.  Made sure Full Client is un-checked.  (now running game at reduced textures, no longer at high res)  (Game ran via aces.exe as well as via Launcher.) :good:

***9.  Made sure Vsync is off.  When I enabled Vsync, I got black screen on Gaijin's and nVidia's loading titles.  Log-in worked OK but didn't have the usual background art.  I have yet to try adaptive Vsync. :dntknw:

 

I'm still not exactly sure why, but it's working as long at I use the reduced texture version.  My existing High res version still won't run.  Thanks for relliK and Hopit for their kindness and patience.

 

Edited by Buzz73
Forgot to mention Vsync issues

Share this post


Link to post
Share on other sites

Just lovely... the problem is back after today's update (update 06.07.2017, v1.69.3.44).  I had a few days of the game running perfectly, but now I have the black screen again. Not sure what is causing this. 

Share this post


Link to post
Share on other sites

Gaijin tech support is trying to pinpoint the problem.  No joy so far.  I'll keep everyone posted as to any solutions that work, as others seem to be having similar problems.

Share this post


Link to post
Share on other sites

I was rather sure I had finally discovered part of the problem last night.  Even though I had checked my firewall settings perhaps 6 times, I failed to realize I was looking at only Outbound Permissions.  Once I expanded the Zone Alarm settings screen, I was able to check all Inbound Permissions.  Once I checked both inbound settings, War Thunder worked again... yesterday.  Although WT worked yesterday, it won't work today.  Rechecked all settings, don't know why is won't run today.:(

WarThunder_ZoneAlarm01.jpg

WarThunder_ZoneAlarm02.jpg

Edited by Buzz73
problem is now intermittent, not solved

Share this post


Link to post
Share on other sites

WT technical support has asked me to make a bug report, so I'll do that.  Will keep everyone posted as to any relevant info.

Share this post


Link to post
Share on other sites

kinda reminds me of my problem with Dragon Age Inquisition oO

it wont start unless i completely disable both my antivirus software and my firewall... once it has started up i can enable the av software and firewall again.

doesn't matter that i've granted access (inbound, outbound, all ports, all protocolls etc) to all executables related to DA:I in the firewall and also excluded

the whole folder (after excluding just the executables) in the av software. so yea, i know what it's like =/ (and without proper error messages it's really hard

to even get an idea about what is causing the issue)... i know it's something (most likely a very tiny thing / detail) on my system but well... at some point i

just gave up looking and now i'm just using the 'workaround' to get it running 8D

 

anyway ^^

dont forget... there has been (yet another) update. so while the connection issues may be out of the way now this may be a completely different problem.

(though, you did doublecheck the firewall settings, didn't you ? ^^ sorry - i just couldn't resist hehe)

medal medal medal

Share this post


Link to post
Share on other sites

Thanks, relliK, for the reminder.  Yes, I've checked the firewall settings again today. ;)  But once again, it won't run after today's update.  I also tried disabling both AV and firewalls, rebooting, running the game, et al.  Still won't run.  I've checked Windows Defender settings, Windows Firewall settings as well.  I also have an exemption created for the AntiVirus part of ZoneAlarm, just in case.

 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.