Sign in to follow this  
SuperSaiyan_HUN

[0040242] UNWANTED CONTROL CHANGE (SAITEK X-55 RHINO)

Hi!

I was redirected here by customer support.

I'd like to report a problem regarding the controls. I've been playing the game for one and a half year now, and for playing I've always used a Saitek X-55 HOTAS System. I spent a lot of time to set the controls and the button layout for it and I would be unable to set the controls again to be exactly the same as I had set them before, because I don't remember how I did it exactly, but I saved the control settings to a .blk file, and I reload them every time i need it. When I had set the controls 1.5 year ago, the game had recognized the Joystick as "J1" (Joystick 1) and the Throttle Controller as "J2" (Joystick 2) and I had set the button layout accordingly to Joystick 1 and Joystick 2. I always launch the game with both the Joystick and the Throttle Controller attached to my PC, and the the Joystick had always been recognized by the game as "J1" (Joystick 1) and the Throttle Controller as "J2" (Joystick 2) until 9 days ago. 9 days ago there was a change. I didn't do any modification neither in my system nor in the controls, but since that day the game recognizes the Joystick as "J2" (Joystick 2) and the Throttle controller as "J1" (Joystick 1) if I lauch the game with both controllers attached, so now my button layout is messed up, and I cannot use the X-55 Rhino anymore like this. I cannot change this, it's the game. 
I've only found a temporary solution. If i launch the game with only the Joystick attached to my PC, the game still recognizes it as "J1" (Joystick 1), and then I have to attach the Throttle Controller in-game to be reconized as "J2" (Joystick 2). This way I can still use the X-55 Rhino, but it's very annoying that i have to unplug and replug the Throttle Controller every time I launch the game. As I mentioned before setting the button layout again is not possible for me, because i don't remember how I did it, so I'm asking you that whatever change you made accidentally or intentionally in the controls, change it back please. The X-55 Rhino Joystick should be recognized as "J1" again and the Throttle Controller should be "J2" again. I'm absolutely positive that this change has nothing to do with the X-55, but with the game.

I hope my english was good enough to explain my problem, if something is unclear, feel free to ask questions.

 

Thank you.

Best Regards, 
Peter Orgovanyi

FredericusRer (Posted )

Please be aware that after 48 hours, if no response is given, the report will be closed and you will need to resubmit the issue in a new thread.

Thank you.
  • Upvote 1
medal medal medal medal medal medal

Share this post


Link to post
Share on other sites
Hello, SuperSayanHUN.

Please provide all the information and data required in the guidelines here as your report is currently incomplete.
Additionally, please explain your issue with detailed screenhots for better understanding.
medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

Hello!

 

Thanks for publishing my report, I'm sorry if it was a bit complicated.

 

I try to explain the issue as simply as I can.

 

The Saitek X-55 Rhino H.O.T.A.S has 2 parts. (http://www.saitek.com/uk/prod/x55.html)

 

It contains a Joystick and a Throttle Controller. They have to be connected separately to the PC, they have their own USB cables, so they are 2 separate controllers.

 

I always lauch the game with both controllers connected to the PC.

 

Until recently the Joystick, I mean the "Stick" was "Joystick 1" (J1) and the Throttle Controller was "Joystick 2" (J2). A couple of days ago they were reversed by the game for unknown reason.

 

Now the stick has become "Joystick 2" (J2) and the Throttle Controller has become "Joystick 1" (J1). I cannot change this, the game decides which is which.

 

The Joystick is supposed to be "Joystick 1" (J1) and the Throttle Controller is supposed to be "Joystick 2" (J2) otherwise my button layout which I had set 2 years ago doesn't work, it's messed up now becasuse it was designed for the Joystick as "Joystick 1" and the Throttle Controller as "Joystick 2".  I would have to reset the controls and the button layout, but i can't reset them again.

 

I didn't make any change, the game changed, but why to change it suddenly???

 

The temporary solution is, if I launch the game with only the Joystick connected to the PC, the game recognizes it as "Joystick 1" (obviously because no other controller is connected) and when I'm already in-game, I connect the Throttle Controller too, so it will be the "Joystick 2" (as it should be), and my button layout works again, but this is a rather inconvenient solution.

 

So I want you to make the game recognize the Joystick as "J1" again, and the Throttle Controller as "J2" again if I launch the game with both controllers conncected to the PC.

 

As you requested, i will make a youtube video of the issue in 48 hours for better understanding.

 

That will be all the information I can provide, I hope you will understand the issue.

 

Thank you.

 

 

 

 

 

 

 

1. A detailed description of the issue you have encountered with your device. Also specify the game mode(s) that is/are affected.----- DONE

 

2. If applicable, specify the full name and type of the device. State if the device is running on a specialized software and if so, provide name and version. ---(http://www.saitek.com/uk/down/drivers.php)

 

3. Save your Control settings in game and attach the relevant .blk file to review your issue. ----- DONE

 

4. Attach your system's current DxDiag Log. ----- DONE

 

5. Attach the Client Log of the session in which the error occurred. If the problem is persistent, attach the latest one available. ----- NOT APPLICABLE

 

6. If applicable, add screenshots visualizing your control settings (including axis and slider positioning) or other helpful information. 

 

7. If applicable, link a short video showcasing the issues you are encountering.

 

 

 

 

 

 

medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

Attach the Client Log of the session in which the error occurred. If the problem is persistent, attach the latest one available. ----- NOT APPLICABLE

If no client log provided, then your bug report is invalid.

As you requested, i will make a youtube video of the issue in 48 hours for better understanding.

You can attach this clog file.
medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

Hello!

 

I've attached the clog file, I'm sorry I didn't attach it earlier.

I also share the links to the videos that I made about the issue.

Please be so kind and watch them, and please read the short desriptions, the are not long.

 

Video 1:   https://www.youtube.com/watch?v=xMN-v3VUlCY&feature=youtu.be 

 

Video 2:   https://www.youtube.com/watch?v=ofhC4MWTdhk&feature=youtu.be

 

 

Thank you.

medal medal medal medal medal medal

Share this post


Link to post
Share on other sites
Your information has been forwarded to the developers.
Tracker ID: 0040242

This thread will remain unlocked for one week (7 days) so that anyone with additional information\evidence\examples will have a place to post.
It will also serve as a place where the developers may post questions for you to answer, so please keep up to date here.

Thank you for your help improving the game and your effort. =)

Greeting
FredericusRer
medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

May I ask a question?

Sure.
 

What are the chances of fixing this issue?

Are good. =)
 

Do you have any idea that when will it happen, based on your experience?

Unfortunately no, there is no rhythm.
medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.