Sign in to follow this  
Europa

[0039581] Joystick assignments gets messed up

Hi,

 

My problem is my joystick assignments are changing when ever I plug or unplug controllers. I am using a laptop so I have to uplug them when ever I am mobile.

 

I have multiple controllers,

 

Saitek X65F Hotas joystick,

Logitech Extreme 3D pro joystick

Saitek Throttle Quadrant

Saitek Rudder Pedals,

Playstation 3 gamepad,

Logitect Driving Force GT Wheel

 

 

When ever I plug or unplug one of these the control setup in game changes. Button assignments and axis assignments changes.

For example at one partiucular setup lets say I assign the axis and buttons to logitech 3d Pro and save a profile. I play my game. In the morning I take my laptop with me. Come back home in the evening. I re-plug my controllers and maybe I dont need to plug the wheel and gamepad. When I open the game. I find that , my quadrant is assigned to axis and buttons are all different. So I have to re-assign everything from the beginning. In time, to overcome this issue I save multiple profiles. When this issue occurs. I try and fail the profiles until one gets working.

 

It hasnt been a big issue for mouse control but I am flying SB and use joysticks.

 

It occured to me the problem is cause by directX. DirectX is changing the ID's in some order it detects them. and WT is using the DirectX ID's instead of device VID

 

I have attached some of my config profiles. After the last patch. None worked and I started all over with this file 1.blk

 

This problem is a know issue among sim pilots. I am surprised that this has never been come to your attention until now.

 

To replicate the problem. Plug multiple controllers. Save a control profile. Close the game, Shutdown your computer. Unplug one of the controllers. Restart computer. start your game. Check assignments.

 

Best Regars,

Europa

  • Upvote 2
medal medal medal medal

Share this post


Link to post
Share on other sites

I also observed this also. I have a small problem with my HOTAS and one rudder pedal is disconnecting occasionally. Because of this all the axis are shifted from assigned controls. My solution is to save two controls setups for both cases and (hopefully) check which one works before take of...

medal

Share this post


Link to post
Share on other sites
Hello, Europa.

Your information has been forwarded to the developers.
Tracker ID: 0039581

This thread will remain unlocked for one week (7 days) so that anyone with additional information\evidence\examples will have a place to post.
It will also serve as a place where the developers may post questions for you to answer, so please keep up to date here.

Thank you for your help improving the game and your effort. =)

Greeting
FredericusRer
medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

Ok i'm just adding this in here as i seem to have been suffering this issue likely because i have upgraded my Saitek Evo Force to a Sidewinder Force Feedback 2...

 

Anyway like the OP i have multiple devices plugged in like:

 

Microsoft Sidewinder Force Feedback 2 Joystick (was before today a Saitek Evo Force Joystick)

Saitek Throttle Quadrant

Saitek Rudder Pedals

Track IR 5

Xbox 360 wireless controller plugged in (for power only) to USB and a microsoft wireless dongle to pick it up.

 

When i was using the Evo Force this morning everything was fine until i unplugged it and plugged in my new Sidewinder and tried to assign "Flaps Down, Flaps Up and Gear Toggle" to the HAT. For some reason it would assign 3 buttons instantly for example: J1: button 1, J1: button 21 and J2: Button 10 or something like that. If i unplug the 360 controller and try to assign keys to the hat then everything is fine but then i am without my trim settings that i have bound to the 360 controller.

medal medal medal medal

Share this post


Link to post
Share on other sites

Moved back to active after PM discussion with OP on some further files to add.

Share this post


Link to post
Share on other sites

LOL ok there seems to be a lot of confusion going on... Knights i did PM you back before i wrote this.

 

Anyway i found the clog files with the control issue i mentioned so i am going to add them here anyway, Each .blk file goes with a .colg file one is with the 360 controller plugged in and trying to bind HAT the others are without the 360 controller.

 

 

 

 

 

 

 

FredericusRer (Posted )

Added to report.
medal medal medal medal

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.