Messer_Smitt

[Linux] Potential Workaround For Mesa Drivers Black Screen

Hello.

 

If you are experiencing issues regarding a black screen on splash screen, and you are using Mesa-Intel based GPU sets. Then try this workaround. Please make sure you have the latest video drivers by using the Operating Systems command line package manager for example, apt-get, yum, and or rpm install to them automatically. You can always do this manually if you wish. 

 

Now Mesa does utilize environment variables. The environment variable, MESA_GL_VERSION_OVERRIDE, is what you need to use.

 

 

 


 

MESA_GL_VERSION_OVERRIDE=4.1COMPAT ./updater

 

 

 

Documentation for a better understanding 

http://www.mesa3d.org/envvars.html

 

Thanks Higutia7

 

 

If you are suffering from this issue please upload a .clog file when not running the workaround attempt; include you video drivers information (glxinfo | grep "OpenGL") aswell

  • Upvote 3
medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

It works, but what about if I'm runing it from steam? 

At the moment I think it may be impossible but you could always try and make a bash script. 

 

And can you please include a .clog file and your video drivers information? Thanks. 

medal medal medal medal medal medal medal medal medal

Share this post


Link to post
Share on other sites

Hello!

I get a green and then a black screen with music playing when not using the workaround, but I don't have an Intel GPU. The workaround works fine, but then it crashes before entering the hangar.

glxinfo: 

 

 

OpenGL vendor string: X.Org

OpenGL renderer string: Gallium 0.4 on AMD RS780 (DRM 2.43.0, LLVM 3.7.0)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 11.0.3
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 11.0.3
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 11.0.3
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:
 

 

.clog file is attached

Share this post


Link to post
Share on other sites

It works, but what about if I'm runing it from steam? 

on steam, on the installed games, select the game, right click  and select properties.

choose "set launch options"

put

MESA_GL_VERSION_OVERRIDE=4.1COMPAT  %command%

apply and start the game

 

 

by the way, it you want, you can also add some more lines to see some statistics (cpu, vram usage, gpu load and drawing wait time)

 

MESA_GL_VERSION_OVERRIDE=4.1COMPAT  GALLIUM_HUD=".w120.h56.c50fps,.w120.h56cpu+cpu0+cpu1+cpu2+cpu3:100,.w120.h56VRAM-usage+GTT-usage+requested-VRAM+requested-GTT,.h56.w120GPU-load,.h56.w120.dbuffer-wait-time"   %command%

 

it can be useful in mesa to fine tune the warthunder graphic options

medal medal

Share this post


Link to post
Share on other sites

on steam, on the installed games, select the game, right click  and select properties.

choose "set launch options"

put

MESA_GL_VERSION_OVERRIDE=4.1COMPAT  %command%

apply and start the game

 

 

by the way, it you want, you can also add some more lines to see some statistics (cpu, vram usage, gpu load and drawing wait time)

 

MESA_GL_VERSION_OVERRIDE=4.1COMPAT  GALLIUM_HUD=".w120.h56.c50fps,.w120.h56cpu+cpu0+cpu1+cpu2+cpu3:100,.w120.h56VRAM-usage+GTT-usage+requested-VRAM+requested-GTT,.h56.w120GPU-load,.h56.w120.dbuffer-wait-time"   %command%

 

it can be useful in mesa to fine tune the warthunder graphic options

Doesn't work for me. :(

Share this post


Link to post
Share on other sites

Override flag isn't working for me:
 

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.5.4
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 10.5.4
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 10.5.4
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:

Share this post


Link to post
Share on other sites

hi,

 

After i tryed most everything ... i started play in "safe mode" .. and ... still crash .... but not so often times as in past ... not perfect but a litle better.

 

I will put here my last logs , trying giving some data to help to find a stable solution.

 

THX 4 your patiente

 

 

 

40-60 FPS

client: 1.55.3.135

 

 

 

 

this is my safe mode bash script

------------------------------------------

 

#!/bin/bash

cd .steam/steam/steamapps/common/War\ Thunder/

./aces -safe

 

 

 

 

inxi -F

----------

 

blabla@Aspire-6930G:~$ inxi -F

System:    Host: Aspire-6930G Kernel: 3.19.0-51-generic x86_64 (64 bit) Desktop: Gnome Distro: Ubuntu 14.04 trusty
Machine:   System: Acer product: Aspire 6930G
           Mobo: Acer model: Makalu Bios: Acer version: v0.3234 date: 03/03/2009
CPU:       Dual core Intel Core2 Duo CPU P7450 (-MCP-) cache: 3072 KB flags: (lm nx sse sse2 sse3 sse4_1 ssse3)
           Clock Speeds: 1: 800.00 MHz 2: 1600.00 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RV730/M96 [Mobility Radeon HD 4650/5165]
           X.Org: 1.17.1 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1280x720@60.0hz
           GLX Renderer: Gallium 0.4 on AMD RV730 GLX Version: 3.0 Mesa 10.5.9
Audio:     Card-1: Advanced Micro Devices [AMD/ATI] RV710/730 HDMI Audio [Radeon HD 4000 series] driver: snd_hda_intel
           Card-2: Intel 82801I (ICH9 Family) HD Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture ver: k3.19.0-51-generic
Network:   Card-1: Intel WiFi Link 5100 driver: iwlwifi
           IF: wlan0 state: up mac: 00:22:fa:11:fb:f8
           Card-2: Qualcomm Atheros AR8121/AR8113/AR8114 Gigabit or Fast Ethernet driver: ATL1E
           IF: eth0 state: down mac: 00:23:8b:84:cf:38
Drives:    HDD Total Size: 2000.4GB (5.8% used) 1: id: /dev/sdb model: Multi size: 1000.2GB
           2: id: /dev/sdc model: ST9500325AS size: 500.1GB 3: id: /dev/sdd model: ST9500325AS size: 500.1GB
Partition: ID: / size: 457G used: 108G (25%) fs: ext4 ID: swap-1 size: 2.00GB used: 0.00GB (0%) fs: swap
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 48.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 196 Uptime: 1:21 Memory: 947.1/3917.9MB Client: Shell (bash) inxi: 1.9.17

 

 

 

 

GLX info

---------------

 

 

blabla@Aspire-6930G:~$ glxinfo | grep version

server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.5.9
OpenGL core profile shading language version string: 3.30
OpenGL version string: 3.0 Mesa 10.5.9
OpenGL shading language version string: 1.30
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 10.5.9
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00

 

Edited by Seven_Triggers
medal

Share this post


Link to post
Share on other sites

With recent MESA drivers versions ( >= 17.x, probably also >=13.x ) and game version, all this problems should not exist anymore, so you should remove the any MESA_GL_VERSION_OVERRIDE that you may have, as it may cause problems in the future or limit features

medal medal

Share this post


Link to post
Share on other sites
On 9/27/2015 at 2:51 AM, UrielC said:

It works, but what about if I'm runing it from steam? 

You can try this:

In your Warthunder binary directory

echo "#!/bin/bash" > warthunder.sh

echo "MESA_GL_VERSION_OVERRIDE=4.1COMPAT ./updater" >> warthunder.sh

chmod +x warthunder.sh

Pay attention to the second echo. It has a double directional arrows as >> instead of > as in the first echo. >> adds the quoted text to the file while > overwrites the file.

 

Then open Steam and on the upper menu under "Games" chose "Add a Non-Steam game to my library" option.

Then it will open a window for you to chose the executable. Don't use the listed ones but click on the "Browse" button on the bottom of the opened window. Then browse to your war thunder binaries directory in which we created warthunder.sh executable bash script. The default may only show *.desktop files so you should change that to *.* option to see *.sh files. Chose warthunder.sh and press open. Then click on "ADD SELECTED PROGRAMS" button next to the Browse button. This will add warthunder.sh to your Steam Library. You can right click on it and chose properties option to set a more suitable and handsome name for it as it seen in your library like War Thunder Reloaded :) but it's not a must.

Then double click on this new library item and enjoy the game ;)

 

On 11/15/2015 at 0:10 AM, higuita7 said:

It works, but what about if I'm runing it from steam? 

on steam, on the installed games, select the game, right click  and select properties.

choose "set launch options"

put

MESA_GL_VERSION_OVERRIDE=4.1COMPAT  %command%

apply and start the game

 

 

by the way, it you want, you can also add some more lines to see some statistics (cpu, vram usage, gpu load and drawing wait time)

 

MESA_GL_VERSION_OVERRIDE=4.1COMPAT  GALLIUM_HUD=".w120.h56.c50fps,.w120.h56cpu+cpu0+cpu1+cpu2+cpu3:100,.w120.h56VRAM-usage+GTT-usage+requested-VRAM+requested-GTT,.h56.w120GPU-load,.h56.w120.dbuffer-wait-time"   %command%

 

it can be useful in mesa to fine tune the warthunder graphic options

Well I did not read this note before I wrote the upper one. This is a better solution :)

 

medal medal

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.