Jump to content


Photo

How to fix CrossFireX graphical glitches with dual-GPU cards using RadeonPro

amd crossfirex xfire crossfire glitches artifacts problem solution radeonpro ccc

  • Please log in to reply
13 replies to this topic

#1 slikts

slikts

    Aircraftman

  • Members
  • Pip
  • 27
  • 0 Thanks

Posted 11 December 2013 - 12:06 AM

War Thunder does not currently support CrossFireX and the game can have severe graphical glitches if CrossFireX is enabled. I have an AMD HD 6990 dual-GPU graphics card, and it's not possible to disable CrossFireX for multi-GPU cards using the AMD Catalyst Control Center, but the game was working fine for me until it suddenly started looking like this and was basically unplayable. I tried things like reinstalling the drivers and it didn't help, but then I discovered that it's possible to disable CrossFireX even for multi-GPU cards using a free 3rd party tool called RadeonPro. I created a profile for aces.exe using this tool and used the slider under Tweaks CrossFireX Tweaks to turn it off for War Thunder and it solved the graphical glitches problem.

 

Hope this info helps someone, cheers.

 

Edit: RadeonPro is not required after all; going to AMD Catalyst Control Center → Gaming → 3D Application Settings allows you to create profiles for applications; just press Add …, find the path to aces.exe, and then there will be an option at the end to set CrossFireX to Disabled.


Edited by slikts, 18 December 2013 - 10:19 PM.

  • 6

#2 MioAkiyama

MioAkiyama

    Mio2GulagPls

  • Banned
  • PipPipPipPip
  • 1,407
  • 0 Thanks

Posted 11 December 2013 - 12:10 AM

Give the man a +1!


  • 1

rxdOFne.jpg


#3 SubRyan

SubRyan

    Flight lieutenant

  • Members
  • PipPipPipPip
  • 1,038
  • 62 Thanks

Posted 11 December 2013 - 04:07 AM

War Thunder does not currently support CrossFireX and the game can have severe graphical glitches if CrossFireX is enabled. I have an AMD HD 6990 dual-GPU graphics card, and it's not possible to disable CrossFireX for multi-GPU cards using the AMD Catalyst Control Center, but the game was working fine for me until it suddenly started looking like this and was basically unplayable. I tried things like reinstalling the drivers and it didn't help, but then I discovered that it's possible to disable CrossFireX even for multi-GPU cards using a free 3rd party tool called RadeonPro. I created a profile for aces.exe using this tool and used the slider under Tweaks CrossFireX Tweaks to turn it off for War Thunder and it solved the graphical glitches problem.

 

Hope this info helps someone, cheers.

 

You can disable Crossfire in Catalyst Control Center -> open CCC -> Gaming -> 3D Applications Settings -> Click Add -> Find where your aces.exe is stored -> Scroll down to Crossfire X Mode and select disabled -> Save


  • 3

#4 _Gyarados_

_Gyarados_

    Officer cadet

  • Members
  • PipPipPip
  • 431
  • 2 Thanks

Posted 11 December 2013 - 12:55 PM

You don't need third party software for this, I do the same thing that SubRyan did.


  • 0

Sky Kitties [PBKAC] Is Now Available For All Your Post Tanking Trauma!


#5 TheShaolinMonk

TheShaolinMonk

    Master Monk

  • Senior Forum Moderator
  • PipPipPipPip
  • 1,397
  • 185 Thanks

Posted 11 December 2013 - 04:27 PM

CrossfireX worked fine for me until 1.35. Then it started looking like this

 

 

I've been using the AMD catalyst centre to turn crossfire off everytime I play War Thunder, but I hope they fix it in the near future. By the way, I use 2 AMD 7850's (Well, 1 for War Thunder I suppose)


  • 0

  xCd0fAT.pngGIBP0NE.png

 


#6 slikts

slikts

    Aircraftman

  • Members
  • Pip
  • 27
  • 0 Thanks

Posted 11 December 2013 - 07:20 PM

You can disable Crossfire in Catalyst Control Center -> open CCC -> Gaming -> 3D Applications Settings -> Click Add -> Find where your aces.exe is stored -> Scroll down to Crossfire X Mode and select disabled -> Save

You're right, I didn't know about the profiles in CCC, I just knew that there was a separate option to disable CrossFireX that was removed for multi-GPU cards. I tried this and it seems to work.

 

I've been using the AMD catalyst centre to turn crossfire off everytime I play War Thunder, but I hope they fix it in the near future. By the way, I use 2 AMD 7850's (Well, 1 for War Thunder I suppose)

You can use the application profiles to make CrossFireX turn off automatically for WT.


Edited by slikts, 11 December 2013 - 07:21 PM.

  • 0

#7 ZejfiCZ

ZejfiCZ

    Sergeant

  • Members
  • PipPip
  • 112
  • 13 Thanks

Posted 11 December 2013 - 09:31 PM

Guys i have maybe a solution for you. You can use your CrossFireX in WT without those shadow or whatever fragments, but it works only in 1.35 for me (when i was was on the Dev server last time (1.37) it dint work at all, it was horrible). So if you are launching WT just click on the "advanced settings" and there you can find something like "debug settings". Below it are two cells. First is "Render" you must set this one on "win7+" (in cause you are using win7). And the second one "Instancing" let on "auto". Then you can use both of your graphics cards like me  :yes:

 

The problem will be maybe unsolvable after patch 1.37 because of DX11 integration. BUT i saw this problem only on Dev server so it means they could repair it in final version of 1.37.

 

Sorry for my English  :salute:


  • 1

LJVnxiI.jpg


#8 Cpt_Badger

Cpt_Badger

    Sergeant

  • Members
  • PipPip
  • 105
  • 1 Thanks

Posted 19 December 2013 - 02:08 AM

No, unfortunately they didn't fix it in 1.37. The game is unplayable for people with Crossfire setups.

 

I feel so lucky that my premium account actually expired today.


  • 0

warthunderFRBsig.pngjjoystickuser.png      qngs3gk6.png 

| You are not your rig specs. You are not your K/D ratio. You are not your sig. | DEAR GAIJIN: Please implement AMD Crossfire support!


#9 _Carolus_Rex_

_Carolus_Rex_

    Sergeant

  • Members
  • PipPip
  • 82
  • 1 Thanks

Posted 19 December 2013 - 02:27 AM

You may also try rightclicking on the launcher and change compatibly to windows xp SP3...That worked for a buddy of mine who could not turn of Crossfire with the methods above. His card is a Raedon 4870x2....


Edited by _Carolus_Rex_, 19 December 2013 - 02:28 AM.

  • 1

#10 Cpt_Badger

Cpt_Badger

    Sergeant

  • Members
  • PipPip
  • 105
  • 1 Thanks

Posted 19 December 2013 - 02:36 AM

You may also try rightclicking on the launcher and change compatibly to windows xp SP3...That worked for a buddy of mine who could not turn of Crossfire with the methods above. His card is a Raedon 4870x2....

 

This actually solved the issue for me. I was pretty sure it won't do nothing since it would be more logical to set aces.exe to Windows XP SP3 compatibility mode, BUT you actually have to set those properties for the launcher.exe. o.O

 

Thanks!


  • 0

warthunderFRBsig.pngjjoystickuser.png      qngs3gk6.png 

| You are not your rig specs. You are not your K/D ratio. You are not your sig. | DEAR GAIJIN: Please implement AMD Crossfire support!


#11 SorHugh

SorHugh

    Recruit

  • Members
  • 3
  • 0 Thanks

Posted 19 December 2013 - 03:48 AM

That's so weird I had the same problem after 1.37 and that also fixes it for me... It's weird it's launcher.exe and not aces.exe but it works so I can't complain...


  • 0

#12 slikts

slikts

    Aircraftman

  • Members
  • Pip
  • 27
  • 0 Thanks

Posted 19 December 2013 - 11:49 AM

Windows XP only has DirectX 9, so I assume that's why the compatibility mode fix works. Not that it matters, the game is unplayable anyway, I'm facing jets in a previously rank 8 plane…


  • 0

#13 NotErnstUdet

NotErnstUdet

    Sergeant

  • Members
  • PipPip
  • 127
  • 7 Thanks

Posted 26 December 2013 - 06:03 PM

slightly off topic, but since the last patch I no longer get the "Crossfire is enabled do you wish to continue" message. I haven't changed any settings, and my FPS is now much higher.


  • 0

#14 Blue_Max_5000

Blue_Max_5000

    Aircraftman

  • Members
  • Pip
  • 24
  • 0 Thanks

Posted 27 December 2013 - 07:31 PM

Hi

 

I have had all the problems u all mention above but after 1.37 a few days it made some more small patches and after that i dont have a problem anymore, still the warning box about Crossfire tho.

 

I ran on it on xp rendering, that fixed the glitching terrain. But then i switched back to directx11 and suddenly everything was ok again.

 

 


  • 0





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users